PAT甲级1088 Rational Arithmetic (20 分)

For two rational numbers, your task is to implement the basic arithmetics, that is, to calculate their sum, difference, product and quotient.
Input Specification:

Each input file contains one test case, which gives in one line the two rational numbers in the format a1/b1 a2/b2. The numerators and the denominators are all in the range of long int. If there is a negative sign, it must appear only in front of the numerator. The denominators are guaranteed to be non-zero numbers.
Output Specification:

For each test case, print in 4 lines the sum, difference, product and quotient of the two rational numbers, respectively. The format of each line is number1 operator number2 = result. Notice that all the rational numbers must be in their simplest form k a/b, where k is the integer part, and a/b is the simplest fraction part. If the number is negative, it must be included in a pair of parentheses. If the denominator in the division is zero, output Inf as the result. It is guaranteed that all the output integers are in the range of long int.
Sample Input 1:

2/3 -4/2

Sample Output 1:

2/3 + (-2) = (-1 1/3)
2/3 - (-2) = 2 2/3
2/3 * (-2) = (-1 1/3)
2/3 / (-2) = (-1/3)

Sample Input 2:

5/3 0/6

Sample Output 2:

1 2/3 + 0 = 1 2/3
1 2/3 - 0 = 1 2/3
1 2/3 * 0 = 0
1 2/3 / 0 = Inf

题意:猜都能猜到这个题目说的是啥,但是我还是来解释一下题目的意思吧。给你给出两个分数(保证分数如果小于0,只有分子前有“-”,输入保证两个分数都是合法的,也就是不存在分母为0的分数。现在要求你进行加减乘除运算)。注意:这个题目难点其实是格式:(1):将分数化为带分数,也就是整数部分和小数部分。(2)如果分数是负数,那么在输出时一定要带括号。

#include<bits/stdc++.h>
#pragma GCC optimize(2)
#define MAXN 10005
#define maxnode 1000005
#define sigma_size 26
#define md 12345678
#define INF 0x3f3f3f3f
#define pii pair<int,int>
using namespace std;

typedef long long LL;
LL aa,bb,cc,dd;

LL Abs(LL mm)
{
    if(mm<0)
        return -mm;
    return mm;
}

LL gcd(LL a,LL b)
{
    while(b)
    {
        LL m=a;
        a=b;
        b=m%b;
    }
    return a;
}

void show(LL a,LL b)               //显示每一组数字
{
    LL pp=gcd(a,b);
    a=a/pp;
    b=b/pp;
    if(a/b)
    {
        if(a/b<0)
            printf("(");
        if(a%b==0)
            printf("%lld",a/b);
        else
            printf("%lld %lld/%lld",a/b,Abs(a%b),Abs(b));
        if(a/b<0)
            printf(")");
    }
    else
    {
        if(a==0)
            printf("0");
        else
        {
            if(a<0||b<0)
                printf("("),printf("-");
            printf("%lld/%lld",Abs(a),Abs(b));
            if(a<0||b<0)
                printf(")");
        }
    }
}

void caculate()
{
    LL tg=aa*dd+cc*bb;
    LL tp=bb*dd;
    show(aa,bb),printf(" + "),show(cc,dd),printf(" = "),show(tg,tp),printf("\n");
    tg=aa*dd-cc*bb;
    show(aa,bb),printf(" - "),show(cc,dd),printf(" = "),show(tg,tp),printf("\n");
    tg=aa*cc;
    show(aa,bb),printf(" * "),show(cc,dd),printf(" = "),show(tg,tp),printf("\n");
    if(cc==0)
        show(aa,bb),printf(" / "),show(cc,dd),printf(" = "),printf("Inf"),printf("\n");
    else
    {
        tg=aa*dd,tp=bb*cc;
        show(aa,bb),printf(" / "),show(cc,dd),printf(" = "),show(tg,tp),printf("\n");
    }
}
int main()
{
    scanf("%lld/%lld %lld/%lld",&aa,&bb,&cc,&dd);
    caculate();
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值