1097 Deduplication on a Linked List (25 分)

11 篇文章 1 订阅
10 篇文章 0 订阅

Given a singly linked list L with integer keys, you are supposed to remove the nodes with duplicated absolute values of the keys. That is, for each value K, only the first node of which the value or absolute value of its key equals K will be kept. At the mean time, all the removed nodes must be kept in a separate list. For example, given L being 21→-15→-15→-7→15, you must output 21→-15→-7, and the removed list -15→15.
Input Specification:

Each input file contains one test case. For each case, the first line contains the address of the first node, and a positive N (≤10​5​​) which is the total number of nodes. The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the position of the node, Key is an integer of which absolute value is no more than 10​4​​, and Next is the position of the next node.
Output Specification:

For each case, output the resulting linked list first, then the removed list. Each node occupies a line, and is printed in the same format as in the input.
Sample Input:

00100 5
99999 -7 87654
23854 -15 00000
87654 15 -1
00000 -15 99999
00100 21 23854

Sample Output:

00100 21 23854
23854 -15 99999
99999 -7 -1
00000 -15 87654
87654 15 -1

题意:给你给出一个链表,输入给出链表的首地址,给出链表的结点个数。现在让你删除一些元素,比如题目中给出的-7,-15,15,-15,21。我们发现-15取了绝对值之后就是15,这个和后面的15是矛盾的,所以我们把15移出去。这样继续下去。
思路:看完题目就知道这个是一个模拟题,所以我们只需要写就是了,我们遍历一遍链表,之后将元素分为两类,一类是不用删除的,一类是用删除的,然后输出就好了。我感觉这一类题目都是一个套路,存储元素,之后按给定的方式排序,完了之后直接输出就好了。而且输出方式都是一样的先输出两个,完了之后输出三个,最后输出一个-1.就结束了。

#include<bits/stdc++.h>
#pragma GCC optimize(2)
#define MAXN 100010
#define maxnode 2000005
#define sigma_size 26
#define md 12345678
#define INF 0x3f3f3f3f
using namespace std;
typedef long long LL;

int start,n;
struct node
{
    int val,nnext;
    node(int val=0,int nnxt=0):val(val),nnext(nnext){};
};
node P[MAXN];
vector<int> pp[2];
set<int> mp;

int main()
{
    scanf("%d %d",&start,&n);
    for(int i=1;i<=n;i++)
    {
        int pos,vv,nxt;
        scanf("%d",&pos);
        scanf("%d %d",&P[pos].val,&P[pos].nnext);
    }
    int head=start;
    while(head!=-1)
    {
        if(!mp.count(abs(P[head].val)))
            mp.insert(abs(P[head].val)),pp[0].push_back(head);
        else
            pp[1].push_back(head);
        head=P[head].nnext;
    }
    bool first=true;
    for(int i=0;i<2;i++)
    {
        for(int j=0;j<pp[i].size();j++)
        {
            if(first)
                printf("%05d %d ",pp[i][j],P[pp[i][j]].val),first=false;
            else
                printf("%05d\n%05d %d ",pp[i][j],pp[i][j],P[pp[i][j]].val);
        }
        if(pp[i].size())
            printf("-1\n");
        first=true;
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值