LightOJ-1214 (签到题)

题目:

Given two integers, a and b, you should check whether a is divisible by b or not. We know that an integer a is divisible by an integer b if and only if there exists an integer c such that a = b * c.

Input

Input starts with an integer T (≤ 525), denoting the number of test cases.

Each case starts with a line containing two integers a (-10200 ≤ a ≤ 10200) and b (|b| > 0, b fits into a 32 bit signed integer). Numbers will not contain leading zeroes.

Output

For each case, print the case number first. Then print 'divisible' if a is divisible by b. Otherwise print 'not divisible'.

Sample Input

6

101 101

0 67

-101 101

7678123668327637674887634 101

11010000000000000000 256

-202202202202000202202202 -101

Sample Output

Case 1: divisible

Case 2: divisible

Case 3: divisible

Case 4: not divisible

Case 5: divisible

Case 6: divisible

中文翻译:

给出两个整数,ab,你应该检查一下a可被b或者不是。我们知道整数a可以被整数整除。b当且仅当存在整数c使.A=b*c.

输入

输入以整数开头T(≤525),表示测试用例的数量。

每一种情况都从包含两个整数的一行开始。A(-10)200≤a≤10200)b({x}b>0,b符合32位有符号整数)..数字将不包含前导零。

输出量

对于每个案例,首先打印大小写。然后打印“可分”如果a可被b..否则打印“不可分”.

利用(a+b)%mod=(a%mod+b%mod)%mod;(a*b)%mod=(a%mod*b%mod)%mod;

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
#include<map>
#include<set>
#include<stack>
#include<queue>
#include<vector>
#define ll long long
using namespace std;
int t;
ll n;
char a[205];
int main()
{
	cin>>t;
	int ans=0;
	while(t--)
	{
		ans++;
		scanf("%s",a);
		scanf("%lld",&n);
		n=abs(n);
		int i,j,k;
		if(a[0]=='-')
		{
			i=1;
		}
		else i=0;
		int length=strlen(a);
		ll aa=0,m=1;
		for(j=length-1;j>=i;j--)
		{
			aa=(aa+(a[j]-'0')*m)%n;//边读边取模运算 
			m=m*10%n;
		}
		if(aa==0)
		{
			printf("Case %d: divisible\n",ans);
		}
		else printf("Case %d: not divisible\n",ans);
	}
    return 0;
}

边读,边对b取模。注意b为int型

 

附上代码:

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值