LightOJ-1078 Integer Divisibility

D - F是签到题

Time Limit:2000MS Memory Limit:32768KB 64bit IO Format:%lld & %llu
Submit

Status

Practice

LightOJ 1078

uDebug
Description
If an integer is not divisible by 2 or 5, some multiple of that number in decimal notation is a sequence of only a digit. Now you are given the number and the only allowable digit, you should report the number of digits of such multiple.

For example you have to find a multiple of 3 which contains only 1’s. Then the result is 3 because is 111 (3-digit) divisible by 3. Similarly if you are finding some multiple of 7 which contains only 3’s then, the result is 6, because 333333 is divisible by 7.

Input
Input starts with an integer T (≤ 300), denoting the number of test cases.

Each case will contain two integers n (0 < n ≤ 106 and n will not be divisible by 2 or 5) and the allowable digit (1 ≤ digit ≤ 9).

Output
For each case, print the case number and the number of digits of such multiple. If several solutions are there; report the minimum one.

Sample Input
3
3 1
7 3
9901 1
Sample Output
Case 1: 3
Case 2: 6
Case 3: 12


  1. 题意:给定两个数n,d,d是一位数字,问最小的能整除n且只含数字d的数是几位数。
  2. 思路:从后先前分析:随意给定一个只含d的数,这个数可以分为两部分的和:一部分是能被n整除的,另一部分对n的余数。如果这个数不能被n整除,那么这个数就要再多一位了,就等于把现在的数*10+d,现在能被n整除的部分乘10以后依然能被n整除,那么我们就只需考虑现余数的部分了,只要现在余数的部分乘以10+d能被n整除就找到了这个数。
  3. 失误:看到这个题首先考虑到是个大数,不能用一般的运算,就想用字符串保存;然后想了一会发现不行,有考虑用快速幂取模和同余定理吧,又想偏差了,,,,,
  4. 代码如下:

#include<cstdio>

int main()
{
    long long k=0,t,n,d;
    scanf("%lld",&t);
    while(t--)
    {
        scanf("%lld%lld",&n,&d);
        long long cnt=1,r=d;//初始化次数和余数 
        while(r%n)
        {
            r=r%n*10+d;//下一个余数 
            ++cnt;
        }
        printf("Case %lld: %lld\n",++k,cnt);
    }
    return 0;
 } 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值