ACM杭电水题://初学者

ACM:ACM杭电水题:A + B Problem II:Problem DescriptionI have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.

InputThe first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.

OutputFor each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line is the an equation “A + B = Sum”, Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.

Sample Input2
1 2
112233445566778899 998877665544332211
Sample OutputCase 1:
1 + 2 = 3

Case 2:
112233445566778899 + 998877665544332211 = 1111111111111111110

C语言能AC的代码#include<stdio.h>
#include<string.h>
int main(){
 char a[1000],b[1000];
 int num,max;
 scanf("%d",&num);
 getchar();
 for(int i=0;i<num;i++)
 {
  int c[1000],d[1000],sum[1000];
  for(int q=0;q<1000;q++)               //这是初始化数组,要在循环里面,不然会数据测试出错,大的数据会占有其他的数组
  {
   c[q]=0;
   d[q]=0;
   sum[q]=0;
  }
  int j;
  scanf("%s",&a);
  for(j=0;j<strlen(a);j++)
   c[j]=a[strlen(a)-1-j]-48;
  scanf("%s",&b);
  for(j=0;j<strlen(b);j++)
   d[j]=b[strlen(b)-1-j]-48;
  if(strlen(a)>strlen(b))
   max=strlen(a);
  else  max=strlen(b);
  int k=0; 
  for(j=0;j<=max-1;j++)
  { 
   sum[j]=(c[j]+d[j]+k)%10;
   k=(c[j]+d[j]+k)/10;
  }
  printf(“Case %d:\n”,i+1);
  printf("%s + %s = “,a,b);
  if(k!=0)
   printf(“1”);
  for(j=max-1;j>=0;j–)
   printf(”%d",sum[j]);
  if(i>=num-1) printf("\n");
  else printf("\n\n");
 }
 return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值