04-树6 Complete Binary Search Tree (30 分)C++实现

04-树6 Complete Binary Search Tree (30 分)C++实现
#题目
A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:
For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:
10
1 2 3 4 5 6 7 8 9 0
Sample Output:
6 3 8 1 5 7 9 0 2 4

#C++代码

#include<iostream>
#include<vector>
#include<algorithm>
using namespace std;
typedef struct Node Node;
struct Node
{
	int Data;
	Node* L;
	Node* R;
};
Node* creatnode()
{
	Node* p = new Node;
	p->Data = 0;
	p->L = NULL;
	p->R = NULL;
	return p;
}
Node** creattree(int N)
{
	Node** p = new Node * [(N + 1)]{ 0 };
	p[0] = NULL;
	for (int i = 1; i <= N; i++)
	{
		if (p[i] == NULL)
			p[i] = creatnode();
		if ((p[2 * i] == NULL) && ((2 * i) <= N))
		{
			p[2 * i] = creatnode();
			p[i]->L = p[2 * i];
		}
		else p[i]->L = NULL;
		if (p[2 * i + 1] == NULL && (2 * i + 1) <= N)
		{
			p[2 * i + 1] = creatnode();
			p[i]->R = p[2 * i + 1];
		}
		else p[i]->R = NULL;
	}
	return p;
}
void Traverse(Node* T,vector<int>& n)
{
	if (T!=NULL)
	{
		Traverse(T->R, n);
		T->Data = n.back();
		n.pop_back();
		Traverse(T->L, n);
	}	
}
int main()
{
	int N;
	cin >> N;
	Node** p=creattree(N);
	vector<int> n;
	int k;
	for (int i = 1; i <= N; i++)
	{
		cin >> k;
		n.push_back(k);
	}
	sort(n.begin(), n.end());
	Traverse(p[1], n);
	for (int i = 1; i <= N; i++)
	{
		cout << p[i]->Data;
		if (i != N)
			cout << " ";
	}
	system("pause");
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值