【PAT甲级A1064】Complete Binary Search Tree (30分)(c++)

1064 Complete Binary Search Tree (30分)

作者:CHEN, Yue
单位:浙江大学
代码长度限制:16 KB
时间限制:400 ms
内存限制:64 MB

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

The left subtree of a node contains only nodes with keys less than the node’s key.
The right subtree of a node contains only nodes with keys greater than or equal to the node’s key.
Both the left and right subtrees must also be binary search trees.
A Complete Binary Tree (CBT) is a tree that is completely filled, with the possible exception of the bottom level, which is filled from left to right.

Now given a sequence of distinct non-negative integer keys, a unique BST can be constructed if it is required that the tree must also be a CBT. You are supposed to output the level order traversal sequence of this BST.

Input Specification:
Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N distinct non-negative integer keys are given in the next line. All the numbers in a line are separated by a space and are no greater than 2000.

Output Specification:
For each test case, print in one line the level order traversal sequence of the corresponding complete binary search tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input:

10
1 2 3 4 5 6 7 8 9 0

Sample Output:

6 3 8 1 5 7 9 0 2 4

题意:

给出一组数,使得它满足完全二叉搜索树,并层序输出该树元素。

思路:

完全二叉搜索树的性质是,它的中序遍历满足递增数列。因此抓住这个性质在对数列进行排序,然后在中序遍历上做文章。
首先,将一颗完全二叉树按从上至下、从左至右的顺序将每个结点标号为0-N-1,那么任意结点的左右孩子结点的下标为root2+1和root2+2;
其次可以按照中序输出的方式将结点值记录在对应下标数组中。

参考代码:

#include <iostream>
#include <algorithm>
const int maxn=1001;
int n,arr[maxn],level[maxn],index=0;
void dfs(int root){
    if(root>=n)return;
    dfs(root*2+1);
    level[root]=arr[index++];
    dfs(root*2+2);
}
using namespace std;
int main() {
    scanf("%d",&n);
    for(int i=0;i<n;i++)
        scanf("%d",&arr[i]);
    sort(arr,arr+n);
    dfs(0);
    for(int i=0;i<n;i++){
        printf("%d",level[i]);
        printf("%s",i<n-1?" ":"\n");
    }
    return 0;
}

如有错误,欢迎指正

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值