HDU 2019多校训练第一场 D - Vacation

Tom and Jerry are going on a vacation. They are now driving on a one-way road and several cars are in front of them. To be more specific, there are n cars in front of them. The ith car has a length of li, the head of it is si from the stop-line, and its maximum velocity is vi. The car Tom and Jerry are driving is l0 in length, and s0 from the stop-line, with a maximum velocity of v0.
The traffic light has a very long cycle. You can assume that it is always green light. However, since the road is too narrow, no car can get ahead of other cars. Even if your speed can be greater than the car in front of you, you still can only drive at the same speed as the anterior car. But when not affected by the car ahead, the driver will drive at the maximum speed. You can assume that every driver here is very good at driving, so that the distance of adjacent cars can be kept to be 0
.
Though Tom and Jerry know that they can pass the stop-line during green light, they still want to know the minimum time they need to pass the stop-line. We say a car passes the stop-line once the head of the car passes it.
Please notice that even after a car passes the stop-line, it still runs on the road, and cannot be overtaken.
Input
This problem contains multiple test cases.
For each test case, the first line contains an integer n (1≤n≤105,∑n≤2×106), the number of cars.
The next three lines each contains n+1 integers, li,si,vi (1≤si,vi,li≤109). It’s guaranteed that si≥si+1+li+1,∀i∈[0,n−1]
Output
For each test case, output one line containing the answer. Your answer will be accepted if its absolute or relative error does not exceed 10−6.
Formally, let your answer be a, and the jury’s answer is b. Your answer is considered correct if |a−b|max(1,|b|)≤10−6
.
The answer is guaranteed to exist.

Sample Input

1
2 2
7 1
2 1
2
1 2 2
10 7 1
6 2 1

Sample Output

3.5000000000
5.0000000000

————————————————————————————————
英文题对我来说还挺难理解的,
参考了大佬的博客,大致讲一下我对这个题的理解吧
首先是三行,第一行的车长L,第二行的距离终点的S,第三行的速度V,让求的是距离终点最后一辆车的车头达到终点线的最短时间
我原以为S会是按照离终点的距离从小到大给出,但给出的第一个数据是距离终点线最远的那辆车的S
如果要使最后一辆车也能通过终点线,那么前面的车就不能是仅仅通过终点线那么简单,前面的车要给后面的车留出后面车长的位置,
所以,最后一辆车应该行驶的距离是它距离终点线的长度,最后第二辆车因为它不能仅仅是自己车头到达终点线就行,它要再向前行驶把终点线留给最后一辆车,所以最后第二辆车的应该行驶距离就是它的S再加上它的车长L,最后第三辆车应该行驶的距离就是它的S加上它的L和最后第二辆车的L
因为是单车道不能超车,所以即使后面的速度快于前面的,但是它也只能以前面的速度行驶,所以就可以求出每辆车所用的时间,然后找最大值就行了。

#include<iostream>
#include<cstdio> 
using namespace std;
typedef long long LL;
const int maxn=1e6+8;
LL l[maxn],s[maxn],v[maxn],sum[maxn];

int main()
{
	int n;
	while(~scanf("%d",&n))
	{
		sum[0]=0;
		double ans=0;
		for(int i=0;i<=n;i++) 
		{
			scanf("%ld",&l[i]);
			if(i) sum[i]=sum[i-1]+l[i];
		}		
		for(int i=0;i<=n;i++) scanf("%ld",&s[i]);
		for(int i=0;i<=n;i++) scanf("%ld",&v[i]);
		for(int i=0;i<=n;i++)
			ans=max(ans,(sum[i]+s[i])*1.0/v[i]);	
		printf("%.10lf\n",ans);
	}
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值