PAT甲级1065 A+B and C (64bit) (20 分)

1065 A+B and C (64bit) (20 分)

Given three integers A, B and C in (−263,263), you are supposed to tell whether A+B>C.

Input Specification:

The first line of the input gives the positive number of test cases, T (≤10). Then T test cases follow, each consists of a single line containing three integers A, B and C, separated by single spaces.

Output Specification:

For each test case, output in one line Case #X: true if A+B>C, or Case #X: false otherwise, where X is the case number (starting from 1).

Sample Input:

3
1 2 3
2 3 4
9223372036854775807 -9223372036854775808 0

结尾无空行

Sample Output:

Case #1: false
Case #2: true
Case #3: false

结尾无空行

用了两种方法 

一开始虽然知道溢出但是并没有想到用溢出判断大小这种好方法hhh

用cin输入测试点3过不去,所以得用scanf 

方法一:

#include <iostream>

using namespace std;

int main()
{
    int n;
    cin>>n;
    for(int i=0;i<n;i++)
    {
        long long int A,B,C;
        scanf("%lld %lld %lld", &A, &B, &C);
        long long int sum=A+B;
        bool flag=false;
        if(A>0&&B>0)
        {
            if(C>0)
            {
                long long num=C-A;
                if(B>num)
                    flag=true;
            }
            else
                flag=true;
           
        }
        else if(A<0&&B<0)
        {
            if(C<0)
            {
                long long num=C-A;
                if(B>num)
                    flag=true;
            }
        }
        else if(sum>C)
            flag=true;
        if(flag)
            printf("Case #%d: true\n",i+1);
        else
            printf("Case #%d: false\n",i+1);
    }
    return 0;
}

 方法二:

#include <iostream>

using namespace std;

int main()
{
    int n;
    cin>>n;
    for(int i=0;i<n;i++)
    {
        long long int A,B,C;
        scanf("%lld %lld %lld", &A, &B, &C);
        long long int sum=A+B;
        if(A>0&&B>0&&sum<0)
        {
            printf("Case #%d: true\n",i+1);
        }
        else if(A<0&&B<0&&sum>=0)
        {
            printf("Case #%d: false\n",i+1);
        }
        else if(sum>C)
            printf("Case #%d: true\n",i+1);
        else
            printf("Case #%d: false\n",i+1);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值