PAT甲级 1066 Root of AVL Tree (25 分)

1066 Root of AVL Tree (25 分)

An AVL tree is a self-balancing binary search tree. In an AVL tree, the heights of the two child subtrees of any node differ by at most one; if at any time they differ by more than one, rebalancing is done to restore this property. Figures 1-4 illustrate the rotation rules.

F1.jpg

 

F2.jpg

 

Now given a sequence of insertions, you are supposed to tell the root of the resulting AVL tree.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤20) which is the total number of keys to be inserted. Then N distinct integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print the root of the resulting AVL tree in one line.

Sample Input 1:

5
88 70 61 96 120

结尾无空行

Sample Output 1:

70

结尾无空行

Sample Input 2:

7
88 70 61 96 120 90 65

Sample Output 2:

88

手敲平衡树=A= 

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;
class node
{
public:
    int num;
    node*left;
    node*right;
};
node* rotateRightRight(node*root)
{
    node *t=root->right;
    root->right=t->left;
    t->left=root;
    return t;
}
node* rotateLeftLeft(node*root)
{
    node *t=root->left;
    root->left=t->right;
    t->right=root;
    return t;
}
node* rotateRightLeft(node*root)
{
    root->right=rotateLeftLeft(root->right);
    return rotateRightRight(root);
}
node* rotateLeftRight(node*root)
{
    root->left=rotateRightRight(root->left);
    return rotateLeftLeft(root);
}
int get_height(node*root)
{
    if(root==NULL)
        return 0;
    else if(root->left==NULL&&root->right==NULL)
        return 1;

    int h1=get_height(root->left);
    int h2=get_height(root->right);
    return max(h1,h2)+1;
}
node* insert_num(node*root,int i)
{
    if(root==NULL)
    {
        //cout<<"1"<<endl;
        root=new node();
        root->num=i;
        root->left=NULL;
        root->right=NULL;
    }
    else if(i>root->num)
    {
        //cout<<"2"<<endl;
        root->right=insert_num(root->right,i);
        if(get_height(root->right)-get_height(root->left)>1)
        {
            if(i>root->right->num)
                root=rotateRightRight(root);
            else
                root=rotateRightLeft(root);
        }
    }
    else
    {
        //cout<<"3"<<endl;
        root->left=insert_num(root->left,i);
        if(get_height(root->left)-get_height(root->right)>1)
        {
            if(i>root->left->num)
                root=rotateLeftRight(root);
            else
                root=rotateLeftLeft(root);
        }
    }
    return root;
}
int main()
{
    int n;
    scanf("%d",&n);
    node *root=NULL;
    for(int i=0;i<n;i++)
    {
        int num;
        scanf("%d",&num);
        root=insert_num(root,num);
        //cout<<"----"<<endl;
    }
    cout<<root->num<<endl;
    return 0;
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值