poj1201

http://poj.org/problem?id=1201

Description

You are given n closed, integer intervals [ai, bi] and n integers c1, …, cn.
Write a program that:
reads the number of intervals, their end points and integers c1, …, cn from the standard input,
computes the minimal size of a set Z of integers which has at least ci common elements with interval [ai, bi], for each i=1,2,…,n,
writes the answer to the standard output.

Input

The first line of the input contains an integer n (1 <= n <= 50000) – the number of intervals. The following n lines describe the intervals. The (i+1)-th line of the input contains three integers ai, bi and ci separated by single spaces and such that 0 <= ai <= bi <= 50000 and 1 <= ci <= bi - ai+1.

Output

The output contains exactly one integer equal to the minimal size of set Z sharing at least ci elements with interval [ai, bi], for each i=1,2,…,n.

Sample Input

5
3 7 3
8 10 3
6 8 1
1 3 1
10 11 1

Sample Output

6

代码
`

`#include <stdio.h>
#include <string.h>
#include <queue>
#define  maxn 50050
#define  INF 0x3f3f3f
using namespace std;
int vis[maxn],d[maxn],head[maxn],mx=0,ma=INF,n;
struct node
{
    int v,d,next;
}edge[233333];
int cnt=0;
void add(int u,int v,int d)
{
    edge[cnt].v=v;
    edge[cnt].d=d;
    edge[cnt].next=head[u];
    head[u]=cnt++;
}
queue<int >q;
int spfa()
{
    for(int i=ma+1;i<=mx+1;i++)
        d[i]=-INF;
    //d[ma]=0;
    q.push(ma);
    vis[ma]=1;
    while(!q.empty())
    {
        int x=q.front();q.pop();
        vis[x]=0;
        for(int i=head[x];i!=-1;i=edge[i].next)
        {
            int t=edge[i].v;
            if(d[t]<d[x]+edge[i].d)
            {
                d[t]=d[x]+edge[i].d;
                //printf("%d %d %d\n",d[t],d[x],edge[i].d);
                if(!vis[t])
                {
                    q.push(t);
                    vis[t]=1;
                }
            }
        }
    }
    return d[mx];
}
int main()
{
    memset(head,-1,sizeof(head));
    scanf("%d",&n);
    while(n--)
    {
        int a,b,c;
        scanf("%d %d %d",&a,&b,&c);
        add(a,b+1,c);
        mx=max(mx,b);
        ma=min(ma,a);
    }
    mx++;
    for(int i=ma;i<mx;i++)
    {
        add(i,i+1,0);
        add(i+1,i,-1);
    }
    printf("%d\n",spfa());
    
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值