poj 3255 Roadblocks(次短路板子题)

Roadblocks

Bessie has moved to a small farm and sometimes enjoys returning to visit one of her best friends. She does not want to get to her old home too quickly, because she likes the scenery along the way. She has decided to take the second-shortest rather than the shortest path. She knows there must be some second-shortest path.
The countryside consists of R (1 ≤ R ≤ 100,000) bidirectional roads, each linking two of the N (1 ≤ N ≤ 5000) intersections, conveniently numbered 1…N. Bessie starts at intersection 1, and her friend (the destination) is at intersection N.
The second-shortest path may share roads with any of the shortest paths, and it may backtrack i.e., use the same road or intersection more than once. The second-shortest path is the shortest path whose length is longer than the shortest path(s) (i.e., if two or more shortest paths exist, the second-shortest path is the one whose length is longer than those but no longer than any other path).
Input
Line 1: Two space-separated integers: N and R
Lines 2… R+1: Each line contains three space-separated integers: A, B, and D that describe a road that connects intersections A and B and has length D (1 ≤ D ≤ 5000)
Output
Line 1: The length of the second shortest path between node 1 and node N
Sample Input
4 4
1 2 100
2 4 200
2 3 250
3 4 100
Sample Output
450
Hint
Two routes: 1 -> 2 -> 4 (length 100+200=300) and 1 -> 2 -> 3 -> 4 (length 100+250+100=450

题目描述:
贝茜把家搬到了一个小农场,但她常常回到FJ的农场去拜访她的朋友。贝茜很喜欢路边的风景,不想那么快地结束她的旅途,于是她每次回农场,都会选择第二短的路径,而不象我们所习惯的那样,选择最短路。 贝茜所在的乡村有R(1<=R<=100,000)条双向道路,每条路都联结了所有的N(1<=N<=5000)个农场中的某两个。贝茜居住在农场1,她的朋友们居住在农场N(即贝茜每次旅行的目的地)。 贝茜选择的第二短的路径中,可以包含任何一条在最短路中出现的道路,并且,一条路可以重复走多次。当然咯,第二短路的长度必须严格大于最短路(可能有多条)的长度,但它的长度必须不大于所有除最短路外的路径的长度。

思路:
使用dijstra算法。对于dijstra算法,有一个结论就是,当一个点第k次出队的时候,此时路径长度就是s到它的第k短路。
dis1,dis2数组分别记录到该点的最短路和次短路
分三种情况:
1.若该点最短路+下一条边比到下个点的最短路短,则更新下个点的最短路,同时更新次短路为原最短路
2.若该点次短路+下一条边比到下个点的次短路短,则更新下个点的次短路
3.若该点最短路+下一条边比到下个点的最短路长同时比下个点的次短路短,则更新下个点的次短路

#include<cstdio>
#include<cstring>
#include<algorithm>
#define mx 100010
#define inf 0x3f3f3f3f
using namespace std;
int N,R,frt[5010],next[mx*2];
int g,dis1[5010],dis2[5010],v[5010],v1[mx*2],v2[mx*2],v3[mx*2];
void add(int x,int y,int z)
{
    v1[g]=x,v2[g]=y,v3[g]=z;
    next[g]=frt[v1[g]];
    frt[v1[g]]=g;
    g++;
}
void dijstr(int sr,int f[])
{
    int i,j,k,u,mi;
    memset(v,0,sizeof(v));
    for(i=1; i<=N; i++)
        f[i]=inf;
    for(i=frt[sr]; i!=-1; i=next[i])
        f[v2[i]]=min(f[v2[i]],v3[i]);
    v[sr]=1,f[sr]=0;
    for(i=1; i<N; i++)
    {
        u=0,mi=inf;
        for(j=1; j<=N; j++)
        {
            if(v[j]==0&&f[j]<mi)
            {
                mi=f[j];
                u=j;
            }
        }
        if(u==0)
            break;
        v[u]=1;
        for(k=frt[u]; k!=-1; k=next[k])
        {
            if(f[v2[k]]>f[u]+v3[k])
                f[v2[k]]=f[u]+v3[k];
        }
    }
    return;
}
int main()
{
    while(~scanf("%d%d",&N,&R))
    {
        g=0;
        int i,j,h,t1,t2,t3;
        memset(v,0,sizeof(v));
        memset(frt,-1,sizeof(frt));
        for(i=0; i<R; i++)
        {
            scanf("%d%d%d",&t1,&t2,&t3);
            add(t1,t2,t3);
            add(t2,t1,t3);
        }
        dijstr(1,dis1);
        dijstr(N,dis2);
        int mi=inf;
        for(i=0; i<g; i++)
        {
            int d=dis1[v1[i]]+dis2[v2[i]]+v3[i];
            if(d>dis1[N]&&mi>d)
                mi=d;
        }
        printf("%d\n",mi);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值