POJ 3259 Wormholes

Wormholes

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ’s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1…N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself ? .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input
Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2… M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2… M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.
Output
Lines 1… F: For each farm, output “YES” if FJ can achieve his goal, otherwise output “NO” (do not include the quotes).
Sample Input
2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8
Sample Output
NO
YES
Hint
For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.
题意:
John的农场里field块地,path条路连接两块地,hole个虫洞,虫洞是一条单向路,不但会把你传送到目的地,而且时间会倒退Ts。我们的任务是知道会不会在从某块地出发后又回来,看到了离开之前的自己。
思路:
判断是否有负权回路,bf(Bellman-Ford)模板,对所有点进行n-1次松弛操作,如果不存在负权回路,就找找出了所有点到起点的最短路,否则还能继续松弛。
松弛操作:如果一个点p到起点start的距离大于从起点到另一个点other,再到p的距离,就把start->p的距离修改为start->other->p的距离,这个叫松弛。
注意:
Bellman-ford算法是求含负权图的单源最短路径算法,效率很低,但代码很容易写。即进行不停地松弛(原文是这么写的,为什么要叫松弛,争议很大),每次松弛把每条边都更新一下,若n-1次松弛后还能更新,则说明图中有负环,无法得出结果,否则就成功完成。Bellman-ford算法有一个小优化:每次松弛先设一个旗帜flag,初值为FALSE,若有边更新则赋值为TRUE,最终如果还是FALSE则直接成功退出。Bellman-ford算法浪费了许多时间做无必要的松弛,所以SPFA算法用队列进行了优化,效果十分显著,高效难以想象。(这段摘自(https://blog.csdn.net/nlp180720/article/details/81295652))
我不会SPFA,所以用了Bellman-ford。

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define inf 0x3f3f3f3f
int n,m,w,dis[510],vis[510],bk[510];
int g,v1[6000],v2[6000],v3[6000];
void add(int x,int y,int z)
{
    v1[g]=x;
    v2[g]=y;
    v3[g]=z;
    g++;
}
void bema(int u)
{
    int i,j,fg=0;
    memset(dis,inf,sizeof(dis));
    dis[u]=0;
    for(i=1; i<=n-1; i++)
    {
        for(j=0; j<g; j++)
        {
            if(dis[v2[j]]>dis[v1[j]]+v3[j])
                dis[v2[j]]=dis[v1[j]]+v3[j];
        }
    }
    for(j=0; j<g; j++)
    {
        if(dis[v2[j]]>dis[v1[j]]+v3[j])
    {
        fg=1;
        break;
    }
}
if(fg)
        printf("YES\n");
    else
        printf("NO\n");
}
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        g=0;
        int i,j,k,t1,t2,t3,fg=0;
        scanf("%d%d%d",&n,&m,&w);
        for(i=0; i<m; i++)
        {
            scanf("%d%d%d",&t1,&t2,&t3);
            add(t1,t2,t3);
            add(t2,t1,t3);
        }
        for(i=0; i<w; i++)
        {
            scanf("%d%d%d",&t1,&t2,&t3);
            add(t1,t2,-t3);
        }
        bema(1);
    }
return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值