NYOJ 221 Tree (二叉树遍历)

Tree

Little Valentine liked playing with binary trees very much. Her favorite game was constructing randomly
looking binary trees with capital letters in the nodes.
This is an example of one of her creations:
在这里插入图片描述
To record her trees for future generations, she wrote down two strings for each tree: a preorder
traversal (root, left subtree, right subtree) and an inorder traversal (left subtree, root, right subtree).
For the tree drawn above the preorder traversal is DBACEGF and the inorder traversal is ABCDEFG.
She thought that such a pair of strings would give enough information to reconstruct the tree later
(but she never tried it).
Now, years later, looking again at the strings, she realized that reconstructing the trees was indeed
possible, but only because she never had used the same letter twice in the same tree.
However, doing the reconstruction by hand, soon turned out to be tedious.
So now she asks you to write a program that does the job for her!
Input
The input file will contain one or more test cases.
Each test case consists of one line containing two strings ‘preord’ and ‘inord’, representing the
preorder traversal and inorder traversal of a binary tree. Both strings consist of unique capital letters.
(Thus they are not longer than 26 characters.)
Input is terminated by end of file.
Output
For each test case, recover Valentine’s binary tree and print one line containing the tree’s postorder
traversal (left subtree, right subtree, root).
Sample Input
DBACEGF ABCDEFG
BCAD CBAD
Sample Output
ACBFGED
CDAB

题意:
输入两组数据,分别是前序遍历序列和中序遍历序列,你需要编写程序通过这两组数据求出该树的后序遍历序列
思路:
我们可以自己模拟一遍推导后续序列。在推导过程中我们会发现:
假设
前序序列是 A B E H F C G I
中序序列是 H E B F A C I G
每一次从前序序列里,按顺序抽取出字母就能将中序序列分割,并根据中序遍历的特性。分割后的两部分分别是
左子树 和 右子树(注意,他们也是二叉树!)
就像这样:
取A, 中序序列被分割为 左子树:H E B F 右子树 C I G
继续取B,但是这次是对左子树:
H E B F 进行分割

分割结果是:
左子树:H E 右子树 B F
直到不能再分割,递归会返回去到第一次使用 A 分割出来的 **右子树 **重复上述过程。
代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
using namespace std;
struct node
{
    char ch;
    node *left,*right;
};
node *build(char *pre,char *in,int len)
{
    int k;
    if(len<=0)//
        return NULL;
    node *head=(node*)malloc(sizeof(node));//malloc()是动态内存分配函数,用来向系统请求分配内存空间。
    head->ch=*pre;
    char *p;
    for(p=in; p!=NULL; p++)
    {
        if(*p==*pre)//在中序遍历的序列中得到与前序相同的节点
            break;
    }
    k=p-in;
    head->left=build(pre+1,in,k);//递归得到左子树
    head->right=build(pre+k+1,p+1,len-k-1);//右子树
    return head;
}
void pain(node *head)//后序遍历
{
    if(head==NULL)
        return ;
    pain(head->left);
    pain(head->right);
    cout<<head->ch;
}
int main()
{
    char pre[30],in[30];
    node *head;
    head=(node*)malloc(sizeof(node));
    while(cin>>pre>>in)
    {
        int len=strlen(pre);
        head=build(pre,in,len);
        pain(head);
        cout<<endl;
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值