1103 Integer Factorization (30point(s))

1103 Integer Factorization (30point(s))

The K−P factorization of a positive integer N is to write N as the sum of the P-th power of K positive integers. You are supposed to write a program to find the K−P factorization of N for any positive integers N, K and P.

Input Specification:
Each input file contains one test case which gives in a line the three positive integers N (≤400), K (≤N) and P (1<P≤7). The numbers in a line are separated by a space.

Output Specification:
For each case, if the solution exists, output in the format:

N = n[1]^P + … n[K]^P
where n[i] (i = 1, …, K) is the i-th factor. All the factors must be printed in non-increasing order.

Note: the solution may not be unique. For example, the 5-2 factorization of 169 has 9 solutions, such as 12
​2
​​ +4
​2
​​ +2
​2
​​ +2
​2
​​ +1
​2
​​ , or 11
​2
​​ +6
​2
​​ +2
​2
​​ +2
​2
​​ +2
​2
​​ , or more. You must output the one with the maximum sum of the factors. If there is a tie, the largest factor sequence must be chosen – sequence { a
​1
​​ ,a
​2
​​ ,⋯,a
​K
​​ } is said to be larger than { b
​1
​​ ,b
​2
​​ ,⋯,b
​K
​​ } if there exists 1≤L≤K such that a
​i
​​ =b
​i
​​ for i<L and a
​L
​​ >b
​L
​​ .

If there is no solution, simple output Impossible.

Sample Input 1:
169 5 2
Sample Output 1:
169 = 6^2 + 6^2 + 6^2 + 6^2 + 5^2
Sample Input 2:
169 167 3
Sample Output 2:
Impossible

#include<bits/stdc++.h>
using namespace std;
int n,k,p;
int maxFacSum=0;
int fac[410];
vector<int> ans,temp;
int init(int n,int p){
    int i=0,temp=0;
    while(temp<=n){
        fac[i++]=temp;
        temp=pow(i,p);
    }
    return i;
}
void dfs(int index,int nowK,int sum,int facSum){
    if(nowK==k&&sum==n){
        if(facSum>maxFacSum){
            ans=temp;
            maxFacSum=facSum;
        }
        return;
    }
    if(sum>n||nowK>k||index==0) return;
    temp.push_back(index);
    dfs(index,nowK+1,sum+fac[index],facSum+index);
    temp.pop_back();
    dfs(index-1,nowK,sum,facSum);
}
int main(){
    scanf("%d%d%d",&n,&k,&p);
    int size=init(n,p);
    dfs(size-1,0,0,0);
    if(ans.empty()){
        printf("Impossible\n");
    }else{
        printf("%d = ",n);
        for(int i=0;i<ans.size();++i){
            if(i!=0) printf(" + ");
            printf("%d^%d",ans[i],p);
        }
        printf("\n");
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值