1004 Counting Leaves (30point(s))

1004 Counting Leaves (30point(s))

A family hierarchy is usually presented by a pedigree tree. Your job is to count those family members who have no child.

Input Specification:
Each input file contains one test case. Each case starts with a line containing 0<N<100, the number of nodes in a tree, and M (<N), the number of non-leaf nodes. Then M lines follow, each in the format:

ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 01.

The input ends with N being 0. That case must NOT be processed.

Output Specification:
For each test case, you are supposed to count those family members who have no child for every seniority level starting from the root. The numbers must be printed in a line, separated by a space, and there must be no extra space at the end of each line.

The sample case represents a tree with only 2 nodes, where 01 is the root and 02 is its only child. Hence on the root 01 level, there is 0 leaf node; and on the next level, there is 1 leaf node. Then we should output 0 1 in a line.

Sample Input:
2 1
01 1 02
Sample Output:
0 1
DFS

#include<bits/stdc++.h>
using namespace std;
const int maxn=110;
vector<int> Node[maxn];
int leaf[maxn]={0};
int maxDepth=0;
void DFS(int index,int depth){
    if(Node[index].empty()){
        leaf[depth]++;
        if(depth>maxDepth){
            maxDepth=depth;
        }
    }
    for(int i=0;i<Node[index].size();++i)
        DFS(Node[index][i],depth+1);
}
int main(){
    int n,m,id,k,child;
    scanf("%d%d",&n,&m);
    for(int i=1;i<=m;++i){
        scanf("%d%d",&id,&k);
        for(int j=0;j<k;++j){
            scanf("%d",&child);
            Node[id].push_back(child);
        }
    }
    DFS(1,1);
    for(int i=1;i<=maxDepth;++i){
        if(i!=1) printf(" ");
        printf("%d",leaf[i]);
    }
    printf("\n");
}

BFS

#include<bits/stdc++.h>
using namespace std;
const int maxn=110;
struct node{
    vector<int> child;
    int depth;
}Node[maxn];
int leaf[maxn]={0};
int maxDepth=0;
void BFS(int index){
    queue<int> q;
    q.push(index);
    Node[index].depth=1;
    while(!q.empty()){
        int now=q.front();
        if(Node[now].child.empty()) leaf[Node[now].depth]++;
        if(Node[now].depth>maxDepth) maxDepth=Node[now].depth;
        q.pop();
        for(int i=0;i<Node[now].child.size();++i){
            int child=Node[now].child[i];
            Node[child].depth=Node[now].depth+1;
            q.push(child);
        }
    }
}
int main(){
    int n,m,id,k,child;
    scanf("%d%d",&n,&m);
    for(int i=1;i<=m;++i){
        scanf("%d%d",&id,&k);
        for(int j=0;j<k;++j){
            scanf("%d",&child);
            Node[id].child.push_back(child);
        }
    }
    BFS(1);
    for(int i=1;i<=maxDepth;++i){
        if(i!=1) printf(" ");
        printf("%d",leaf[i]);
    }
    printf("\n");
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值