POJ 3616 Milking Time

Milking Time

Time Limit: 1000MS Memory Limit: 65536K

Description

Bessie is such a hard-working cow. In fact, she is so focused on maximizing her productivity that she decides to schedule her next N (1 ≤ N ≤ 1,000,000) hours (conveniently labeled 0…N-1) so that she produces as much milk as possible.

Farmer John has a list of M (1 ≤ M ≤ 1,000) possibly overlapping intervals in which he is available for milking. Each interval i has a starting hour (0 ≤ starting_houri ≤ N), an ending hour (starting_houri < ending_houri ≤ N), and a corresponding efficiency (1 ≤ efficiencyi ≤ 1,000,000) which indicates how many gallons of milk that he can get out of Bessie in that interval. Farmer John starts and stops milking at the beginning of the starting hour and ending hour, respectively. When being milked, Bessie must be milked through an entire interval.

Even Bessie has her limitations, though. After being milked during any interval, she must rest R (1 ≤ R ≤ N) hours before she can start milking again. Given Farmer Johns list of intervals, determine the maximum amount of milk that Bessie can produce in the N hours.

Input

  • Line 1: Three space-separated integers: N, M, and R
  • Lines 2…M+1: Line i+1 describes FJ’s ith milking interval withthree space-separated integers: starting_houri , ending_houri , and efficiencyi

Output

  • Line 1: The maximum number of gallons of milk that Bessie can product in the N hours

Sample Input

12 4 2
1 2 8
10 12 19
3 6 24
7 10 31

Sample Output

43

思路:

先用结构体存储信息,将其排序(用开始的时间或者结束的时间排序均可行),排序后用双重循环存储dp[i]为当前位置的递增序列的最大值(需要注意的是,两个序列之间是有r为间隔的),而这个最大值是她本身和之前递增序列加上本身效率的最大值,因此就有dp[i] = max(dp[i], dp[j] + node[i].efficiency)最后求全部中的最大值,就是所需要的值了

#include <iostream>
#include <algorithm>
using namespace std;
struct NODE {
	int start;
	int end;
	int efficiency;
};
bool cmp(NODE a, NODE b) {
	return a.start < b.start;
}
NODE node[1010];
int dp[1010] = {0};
int main() {
	int n, m, r, maxn = 0;
	cin >> n >> m >> r;
	for (int i = 1; i <= m; i++) cin >> node[i].start >> node[i].end >> node[i].efficiency;
	sort(node + 1, node + m + 1, cmp);
	for (int i = 1; i <= m; i++) {
		dp[i] = node[i].efficiency;
		for (int j = 1; j <= i; j++) {
			if (node[j].end + r <= node[i].start) dp[i] = max(dp[i], dp[j] + node[i].efficiency);
		}
		maxn = max(maxn, dp[i]);
	}
	cout << maxn << endl;
	return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值