POJ 3061 Subsequence

Subsequence

Time Limit: 1000MS Memory Limit: 65536K

Description

A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.

Input

The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.

Output

For each the case the program has to print the result on separate line of the output file.if no answer, print 0.
Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3

思路:

就是先用sum存到这个点的时候的总和值,然后因为数值要大于题目所给的m值,所以sum[i] + m如果有能够大于这个的第一个值,那么肯定就是i时最小的长度了,这个时候将两个位置相减就行了。

第一种做法:

#include <iostream>
#include <algorithm>
using namespace std;
int main() {
	int k, n, m;
	scanf("%d", &k);
	while (k--) {
		scanf("%d %d", &n, &m);
		int a[100010] = {0}, sum[100010] = {0};
		for (int i = 0; i < n; i++) {
			scanf("%d", &a[i]);
			sum[i + 1] = sum[i] + a[i];
		}
		if (sum[n] < m) {
			cout << "0\n";
			continue;
		} 
		int ans = n;
		for (int i = 0; sum[i] + m <= sum[n]; i++) {
			int t = lower_bound(sum + i, sum + n, sum[i] + m) - sum;
			ans = min(ans, t - i);
		}
		cout << ans << endl;
	}
	return 0;
}
  

第二种做法:

和第一种思路没啥区别,就是省了一个数组。

#include <iostream>
#include <algorithm>
using namespace std;
int main() {
	int n, m, k;
	scanf("%d", &k);
	while (k--) {
		int a[100010];
		scanf("%d %d", &n, &m);
		for (int i = 0; i < n; i++) scanf("%d", &a[i]);
		int s = 0, t = 0, sum = 0, ans = n + 1;
		while (1) {
			while (t < n && sum < m) sum += a[t++];
			if (sum < m) break;
			ans = min(ans, t - s);
			sum -= a[s++];
		}
		if (ans > n) cout << "0\n";
		else cout << ans << endl;
	}
	return 0;
} 
1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合; 、4下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合;、下载 4使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。 1、资源项目源码均已通过严格测试验证,保证能够正常运行; 2、项目问题、技术讨论,可以给博主私信或留言,博主看到后会第一时间与您进行沟通; 3、本项目比较适合计算机领域相关的毕业设计课题、课程作业等使用,尤其对于人工智能、计算机科学与技术等相关专业,更为适合;、 4下载使用后,可先查看README.md或论文文件(如有),本项目仅用作交流学习参考,请切勿用于商业用途。 5、资源来自互联网采集,如有侵权,私聊博主删除。 6、可私信博主看论文后选择购买源代码。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值