POJ 2407 Relatives

Relatives

Time Limit: 1000MS Memory Limit: 65536K

Description

Given n, a positive integer, how many positive integers less than n are relatively prime to n? Two integers a and b are relatively prime if there are no integers x > 1, y > 0, z > 0 such that a = xy and b = xz.

Input

There are several test cases. For each test case, standard input contains a line with n <= 1,000,000,000. A line containing 0 follows the last case.

Output

For each test case there should be single line of output answering the question posed above.

Sample Input

7
12
0

Sample Output

6
4

题意:

给一个n,在n中有多少个x, y符合x > 1, y > 0, z > 0 , a = xy and b = xz, y, z不存在。

思路:

由于不存在a = xy and b = xz, 所以也就是说x = 1 或者 x = 0(题目x > 1),x = 0不可能,所以x = 1,所以就有gcd(a, b) = 1, a, b互质,接着写个欧拉函数就行了。

#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;
int main() {
    int n;
    while (scanf("%d", &n) != EOF && n) {
        int res = n;
        for (int i = 2; i * i <= n; i++) {
            if (n % i == 0) res = res / i * (i - 1);
            while (n % i == 0) n /= i;
        }
        if (n > 1) res = res / n * (n - 1);
        printf("%d\n", res);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值