How Many Tables (简单并查集)

How Many Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 32330    Accepted Submission(s): 16122


Problem Description
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
 

Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
 

Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
 

Sample Input
  
  
2 5 3 1 2 2 3 4 5 5 1 2 5
 

Sample Output
  
  
2 4
 

Author
Ignatius.L
 

Source



题意:比如A B 也就A认识B,B  C 就是B 认识C  ,此时ABC都认识,则为一组, 问最后能有几组;



#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
const int N=1010;
int par[N];
void init(int n)//初始化一个编号为一组
{
for(int i=0;i<=n;i++)
{
par[i]=i;
}
}


int find(int x)//找个这组的第一个
{
if(par[x]==x) return x;
return par[x]=find(par[x]);
}


void unite(int x,int y)//将x,y合为一组
{
x=find(x);y=find(y);
par[y]=x;


}
bool same(int x,int y)
{
return find(x)==find(y);
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int n,m;
scanf("%d %d" ,&n, &m);
init(n);
int i,a,b;
for(i=0;i<m;i++)
{
scanf("%d%d", &a,&b);
if(!same(a,b))
{
unite(a,b);
}
}
int d=0;
for(i=1;i<=n;i++)
{
if(par[i]==i)  d++;
}
printf("%d\n",d);
}
return 0;
}
人一我百!人十我万!永不放弃~~~怀着自信的心,去追逐梦想。


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

じ☆夏妮国婷☆じ

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值