Wrestling Match(图、搜索)

这是一道编程题,描述了一场摔跤比赛中,裁判小明试图将参赛者分为'好选手'和'坏选手'两组。输入包含比赛人数、比赛场次、已知的好选手和坏选手数量,以及具体的比赛对战情况。如果所有选手可以明确分为'好选手'和'坏选手',输出'YES',否则输出'NO'。样例输入和输出展示了不同情况下分类的可能。
摘要由CSDN通过智能技术生成

Problem Description

Nowadays, at least one wrestling match is held every year in our country. There are a lot of people in the game is "good player”, the rest is "bad player”. Now, Xiao Ming is referee of the wrestling match and he has a list of the matches in his hand. At the same time, he knows some people are good players,some are bad players. He believes that every game is a battle between the good and the bad player. Now he wants to know whether all the people can be divided into “good player” and “bad player”.

Input

Input contains multiple sets of data.For each set of data,there are four numbers in the first line:N (1 ≤ N≤ 1000)、M(1 ≤M ≤ 10000)、X,Y(X+Y≤N ),in order to show the number of players(numbered 1toN ),the number of matches,the number of known “good players” and the number of known “bad players”.In the next M lines,Each line has two numbersa, b(a≠b) ,said there is a game between a and b .The next line has X different numbers.Each number is known as a “good player” number.The last line contains Y different numbers.Each number represents a known “bad player” number.Data guarantees there will not be a player number is a good player and also a bad player.

Output

If all the people can be divided into “good players” and "bad players”, output “YES”, otherwise output “NO”.

Sample Input
5 4 0 0
1 3
1 4
3 5
4 5
5 4 1 0
1 3
1 4
3 5
4 5
2

Sample Output

NO
YES

题目意思就是给你n个点和m条边,还有确定的a个点和b个点。a个点是good,b个点是bad ,点与点之间只能 good与bad相连。若不能区分点的good和bad 输出No 否则输出Yes

#include <bits/stdc++.h>
using namespace std;

const int MAX=1e3+5;
int n,m,a,b;
vector<int> G[MAX];
int val[MAX],vis[MAX];

int main(){
   
    int x,y;
    while(~scanf("%d%d%d%d",&n,&m,&a,&b)){
   
        for(int i=1;i<=n;i++)G[i].clear();
        memset
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值