A Walk Through the Forest(最短路+搜索)

描述

Jimmy experiences a lot of stress at work these days, especially since his accident made working difficult. To relax after a hard day, he likes to walk home. To make things even nicer, his office is on one side of a forest, and his house is on the other. A nice walk through the forest, seeing the birds and chipmunks is quite enjoyable.
The forest is beautiful, and Jimmy wants to take a different route everyday. He also wants to get home before dark, so he always takes a path to make progress towards his house. He considers taking a path from A to B to be progress if there exists a route from B to his home that is shorter than any possible route from A. Calculate how many different routes through the forest Jimmy might take.

输入

Input contains several test cases followed by a line containing 0. Jimmy has numbered each intersection or joining of paths starting with 1. His office is numbered 1, and his house is numbered 2. The first line of each test case gives the number of intersections N, 1 < N ≤ 1000, and the number of paths M. The following M lines each contain a pair of intersections a b and an integer distance 1 ≤ d ≤ 1000000 indicating a path of length d between intersection a and a different intersection b. Jimmy may walk a path any direction he chooses. There is at most one path between any pair of intersections.

输出

For each test case, output a single integer indicating the number of different routes through the forest. You may assume that this number does not exceed 2147483647

样例输入

5 6
1 3 2
1 4 2
3 4 3
1 5 12
4 2 34
5 2 24
7 8
1 3 1
1 4 1
3 7 1
7 4 1
7 5 1
6 7 1
5 2 1
6 2 1
0

样例输出

2
4

题意:
起点是1,终点是2,问你从1到2的最短路有几种走法(并不是),真正的意思是:假设 A 和 B 是相连的,当前在 A 处,如果 A 到终点的距离大于 B 到终点的距离,则可以从 A 通往 B 处,问满足这种的条件的数量(路径条数)。

用dis记录2到各个点的最短距离,dfs返回的是从2出发 到这个点的数量(路径条数) 并用dis2记录。
已经存在就直接返回该点的条数,若该点是2就返回1,否则每次加上所有的能到达该点的数量(路径条数)

#include <bits/stdc++.h>
using namespace std;
#define inf 0x3f3f3f3f
#define N 1005
int n,m,x,z,y;
int mp[N][N];
int vis[N],dis[N];
int dis2[N];
void f(int kk){
    memset(vis,0,sizeof(vis));
    for(int i=1;i<=n;i++){
        dis[i]=mp[kk][i];
    }
    dis[kk]=0;
    vis[kk]=1;
    for(int i=1;i<n;i++){
        int mi=inf,k=0;
        for(int j=1;j<=n;j++){
            if(vis[j]==0&&dis[j]<mi){
                mi=dis[j];
                k=j;
            }
        }
        vis[k]=1;
        for(int j=1;j<=n;j++){
            if(vis[j]==0){
                dis[j]=min(dis[j],dis[k]+mp[k][j]);
            }
        }
    }

}
int dfs(int k){
    if(dis2[k]) return dis2[k];
    if(k==2){
        return 1;
    }
    int sum=0;
    for(int i=1;i<=n;i++){
        if(dis[k]>dis[i]&&mp[k][i]!=inf){
            sum+=dfs(i);
        }
    }
    dis2[k]=sum;
    return dis2[k];
}
int main(){
    while(scanf("%d",&n),n){
        memset(mp,inf,sizeof(mp));
        scanf("%d",&m);
        for(int i=0;i<m;i++){
            scanf("%d%d%d",&x,&y,&z);
            mp[x][y]=z;mp[y][x]=z;
        }
        f(2);

        memset(dis2,0,sizeof(dis2));
        printf("%d\n",dfs(1));
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值