Bi-shoe and Phi-shoe

Bamboo Pole-vault is a massively popular sport in Xzhiland. And Master Phi-shoe is a very popular coach for his success. He needs some bamboos for his students, so he asked his assistant Bi-Shoe to go to the market and buy them. Plenty of Bamboos of all possible integer lengths (yes!) are available in the market. According to Xzhila tradition,

Score of a bamboo = Φ (bamboo's length)

(Xzhilans are really fond of number theory). For your information, Φ (n) = numbers less than n which are relatively prime (having no common divisor other than 1) to n. So, score of a bamboo of length 9 is 6 as 1, 2, 4, 5, 7, 8 are relatively prime to 9.

The assistant Bi-shoe has to buy one bamboo for each student. As a twist, each pole-vault student of Phi-shoe has a lucky number. Bi-shoe wants to buy bamboos such that each of them gets a bamboo with a score greater than or equal to his/her lucky number. Bi-shoe wants to minimize the total amount of money spent for buying the bamboos. One unit of bamboo costs 1 Xukha. Help him.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 10000) denoting the number of students of Phi-shoe. The next line contains n space separated integers denoting the lucky numbers for the students. Each lucky number will lie in the range [1, 106].

Output

For each case, print the case number and the minimum possible money spent for buying the bamboos. See the samples for details.

Sample Input

3

5

1 2 3 4 5

6

10 11 12 13 14 15

2

1 1

Sample Output

Case 1: 22 Xukha

Case 2: 88 Xukha

Case 3: 4 Xukha

 题意:一个竹竿长度为p,它的分值就是比n长度小且与p互质的数字总和。输入一个数n ,表示有n个学生,每个学生都有一个幸运数字,买n个竹子,每个竹子的分都要大于或等于该学生的幸运数字,而且每个竹竿的长度为购买这个竹竿的花费,求最少需要花费多少钱。

题解:欧拉函数的使用与埃氏筛法(素数打表)。

欧拉函数:f(n)=n((1-1/p1)*(1-1/p2)*(1-1/p3)*....*(1-1/pr) 化简得:f(n)=n((p1-1)/p1*(p2-1)/p2*...(pr-1)/pr);

欧拉函数:在数论中,对正整数n,欧拉函数是小于n的正整数中与n互质的数的数目。

 比如:1的欧拉函数f(1)=1,8的欧拉函数f(8)=4;

欧拉函数是积性函数——若m,n互质, f(m*n)=f(n)*f(m);

特殊性质:当n为奇质数时,f(2*n)=f(n);

若n为质数则 f(n)=n-1;

 

#include<stdio.h>
#include<string.h>
int a[10010];
int book[1001000];
int main()
{
    memset(book,0,sizeof(book));
    book[1]=book[0]=1;
    for(int i=2; i<1000; i++)
    {
        if(book[i]==0)
        {
            for(int j=i*2; j<1001000; j+=i)
            {
                book[j]=1;//非素数
            }
        }
    }
    int t,o=1;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        memset(a,0,sizeof(a));
        scanf("%d",&n);
        for(int i=0; i<n; i++)
            scanf("%d",&a[i]);
        long long res=0;//**********
        for(int i=0; i<n; i++)
        {
            for(int j=a[i]+1;;j++)
            {
                if(book[j]==0)
                {
                    res+=j;
                    break;
                }
            }
        }
        printf("Case %d: %lld Xukha\n",o++,res);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值