LightOJ - 1370 Bi-shoe and Phi-shoe(欧拉函数)

Bamboo Pole-vault is a massively popular sport in Xzhiland. And Master Phi-shoe is a very popular coach for his success. He needs some bamboos for his students, so he asked his assistant Bi-Shoe to go to the market and buy them. Plenty of Bamboos of all possible integer lengths (yes!) are available in the market. According to Xzhila tradition,

Score of a bamboo = Φ (bamboo's length)

(Xzhilans are really fond of number theory). For your information, Φ (n) = numbers less than n which are relatively prime (having no common divisor other than 1) to n. So, score of a bamboo of length 9 is 6 as 1, 2, 4, 5, 7, 8 are relatively prime to 9.

The assistant Bi-shoe has to buy one bamboo for each student. As a twist, each pole-vault student of Phi-shoe has a lucky number. Bi-shoe wants to buy bamboos such that each of them gets a bamboo with a score greater than or equal to his/her lucky number. Bi-shoe wants to minimize the total amount of money spent for buying the bamboos. One unit of bamboo costs 1 Xukha. Help him.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case starts with a line containing an integer n (1 ≤ n ≤ 10000) denoting the number of students of Phi-shoe. The next line contains n space separated integers denoting the lucky numbers for the students. Each lucky number will lie in the range [1, 106].

Output

For each case, print the case number and the minimum possible money spent for buying the bamboos. See the samples for details.

Sample Input

3

5

1 2 3 4 5

6

10 11 12 13 14 15

2

1 1

Sample Output

Case 1: 22 Xukha

Case 2: 88 Xukha

Case 3: 4 Xukha

-------------------------------------------------->
题意就是给出n个整数,
每个整数ai找出最小的xi使得Φ(xi)>=ai,求x1+x2+...+xn。
Φ(xi)就是1~(xi-1)中有多少个数与xi互质

利用欧拉函数筛先把每个数的欧拉函数值筛出来(注意maxn一定要设大一点,要保证maxn欧拉函数的值比ai的最大值要大),然后再预处理一波花费xi最多能得到多少价值,这样花费和价值就是单调函数了,就可以利用二分求出最小的花费。

重点是:Bi-shoe wants to buy bamboos such that each of them gets a bamboo with a score greater than or equal to his/her lucky number(每个学生所得的bamboo的score的值必须大于或等于他的幸运数字);

#include <iostream>
#include <cstring>
#include <string>
#include <algorithm>
#include <queue>
#include <stack>
#include <cmath>
using namespace std;
typedef long long ll;
#define maxx 3000000
ll phi[maxx];
ll n;
void euler_table()
{
    phi[1]=0;
    for(int i=2;i<=maxx;i++)
    {
        if(phi[i])
            continue;
        for(int j=i;j<=maxx;j+=i)
        {
            if(!phi[j])
                phi[j]=j;
            phi[j]=phi[j]/i*(i-1);
        }
    }
    for(int i=2;i<=maxx;i++)
    {
        phi[i]=max(phi[i],phi[i-1]);//为了二分
    }
}
int binarysearch(int x)
{
    int l=1,r=maxx;
    int ans=r;
    while(l<=r)
    {
        int mid=(l+r)/2;
        if(phi[mid]>=x)
        {
            r=mid-1;
            ans=mid;
        }
        else l=mid+1;
    }
    return ans;
}
int main()
{
    ios::sync_with_stdio(false);
    int t,n;
    euler_table();
    cin>>t;
    for(int i=1;i<=t;i++)
    {
        cin>>n;
        ll sum=0;
        for(int i=1;i<=n;i++)
        {
            int x;
            cin>>x;
            sum+=binarysearch(x);
        }
        cout<<"Case "<<i<<": "<<sum<<" Xukha"<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值