1013. Battle Over Cities (25)

It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.

Input

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input
3 2 3
1 2
1 3
1 2 3
Sample Output
1
0
0

题目大意:

在一场战争中,把所有的城市连接起来是至关重要的。如果一个城市被敌人占领,所有的高速公路都将被关闭。我们必须马上知道我们是否需要修建一些高速公路来保持那些没有被占领的城市之间的畅通。给定城市的地图,没被占领的公路都有标记,你应该尽快求出修建的高速公路的数量。
例如,如果我们有3个城市和2条高速公路连接city1-city2和city1-city3。如果城市1被敌人占领,我们必须有1条高速公路的修复,那就是2-city3公路。
输入
每个输入文件包含一个测试用例。每一种情况都以一个包含3个数字N(<1000)、M和K的线开始,分别是城市的总数、剩余的高速公路的数量和要检查的城市的数量。然后M行,每个描述一个高速公路由两个整数,这是高速公路连接的城市的数量。城市的编号从1到n,最后有一个包含K个数字的线,代表我们关注的城市。
输出
对于每一个K个城市,如果这个城市失去了,就需要对线路的数量进行修复。

代码:

#include<stdio.h>
#include<string.h>
int map[1001][1001],visited[1001],road[1001],n;
void DFS(int start)
{
    int i;
    visited[start]=1;
    for(i=1;i<=n;i++)
    {
        if(visited[i]==0&&map[start][i]==1)
            DFS(i);
    }
}
int main()
{
    int i,j,m,k,t,x,y,num;
    scanf("%d %d %d",&n,&m,&k);
    for(i=0;i<m;i++)
    {
        scanf("%d %d",&x,&y);
        map[x][y]=map[y][x]=1;
    }
    for(i=0;i<k;i++)
    {
        scanf("%d",&road[i]);
    }
    for(i=0;i<k;i++)
    {
        num=0;
        memset(visited,0,sizeof(visited));
        visited[road[i]]=1;
        for(j=1;j<=n;j++)
        {
            if(visited[j]==0)
            {
                DFS(j);
            num++;
            }
        }
        if(i==k-1)
        {
            printf("%d",num-1);
        }
        else
        {
            printf("%d\n",num-1);
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值