【 HDU - 1789 】E - Doing Homework again (贪心)

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

Input

The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework… Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.

Output

For each test case, you should output the smallest total reduced score, one line per test case.

Sample Input

3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4

Sample Output

0
3
5

思路:

核心思想:先将分值大的作业优先完成,以免超时损失较大。

但是一开始想了一会,不知道同一期限的最大值要提前放在哪天合适,后来看了别人的题解。

才懂得了优先完成不一定就要更早完成,而是只要确保能完成,也是一样的
狭隘了狭隘了,贪心还是难啊,看完题解只想说妙哉

先将分数大到小排序,然后开始安排完成日期,如果当天没有安排,那就安排当天,否则往前安排(因为排序的原因,没放的分数必定比当前分数小,所以可以占他的位置)


代码:

#include <iostream>
#include <algorithm>
using namespace std;
const int maxn=1010;
int t,n;

struct node{
	int end,work; //期限,分数
}a[maxn];

bool cmp(node a,node b){ //按工作从大到小
	return a.work>b.work; 
}

int main() 
{
    cin>>t;
    while(t--)
    {
    	cin>>n;
    	for(int i=0;i<n;i++) cin>>a[i].end;
    	for(int i=0;i<n;i++) cin>>a[i].work;
    	sort(a,a+n,cmp);
    	int task[maxn]={0},ans=0; //task安排
    	for(int i=0;i<n;i++)
    	{
    		int day=a[i].end;
    		if(!task[day]) task[day]=a[i].work; //没放,直接放
    		else 
    		{
    			int flag=0; //标记是否放了
    			for(int j=day-1;j>0;j--) //放了找前面
    				if(!task[j])
					{
						task[j]=a[i].work;
						flag=1;
						break;
					} 
				if(!flag) ans+=a[i].work; //没得放,必定超时
			}
		}
		cout<<ans<<endl;	
	}
    return 0;
} 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值