1044 Shopping in Mars (25分)

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).
Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 numbers: N (≤10^​5), the total number of diamonds on the chain, and M (≤10^​8), the amount that the customer has to pay. Then the next line contains N positive numbers Di+………+Dj​​ (for all i=1,⋯,N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print i-j in a line for each pair of i ≤ j such that Di + … + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output i-j for pairs of i ≤ j such that Di + … + Dj >M with (Di + … + Dj −M) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:

16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13

Sample Output 1:

1-5
4-6
7-8
11-11

Sample Input 2:

5 13
2 4 5 7 9

Sample Output 2:

2-4
4-5

题意:
找出所有的数字串,使其和为一个确定的值,如果没有则要求在和大于这个值的情况下尽可能接近。

思路:
1.开一个数组sum[i],表示A[1]到A[N]的和值,为了计算方便初始化sum[0]=0,所以sum[i]是天然递增的。要求A[i]~A[j]的和,只需要求sum[j] - sum[i-1]即可
2.由于sum[]天然递增,因此可以用二分法来做(手写二分法或者使用upper_bound函数)

注释掉的两行是使用upper_bound函数

#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn = 100010;
int sum[maxn];
int n, S, nearS = 100000010;

//返回第一个大于x的数的位置
int upper_bound(int l, int r, int x)
{
    int left = l, right = r, mid;

    while(left < right)
    {
        mid = (left + right) / 2;
        if(sum[mid] > x)
            right = mid;  //为什么不是mid - 1?  而且mid - 1会出错
            //不能是mid-1, 因为函数要返回的是第一个大于x的数的位置,sum[mid] > x 则应该返回mid
        else
            left = mid + 1;
    }
    return left;
}

int main()
{
    scanf("%d%d", &n, &S);
    sum[0] = 0;
    for(int i = 1; i <= n; i++)     //计算前n项的和
    {
        scanf("%d", &sum[i]);
        sum[i] += sum[i - 1];
    }
    for(int i = 1; i <= n; i++)     //枚举左端点
    {
//        int j = upper_bound(sum + i, sum + n + 1, sum[i - 1] + S) -sum;    //求右端点
        int j = upper_bound(i, n + 1, sum[i - 1] + S);
        if(sum[j - 1] - sum[i - 1] == S)    //查找成功(注意是j-1而不是j)
        {
            nearS = S;  //最接近S的值就是S
            break;
        }
        else if(j <= n && sum[j] - sum[i - 1] < nearS)  //存在大于S的解并且小于nearS
            nearS = sum[j] - sum[i - 1];    //更新当前nearS
    }
    for(int i = 1; i <= n; i++)    //求右端点
    {
//        int j = upper_bound(sum + i, sum + n + 1, sum[i - 1] + nearS) - sum;
        int j = upper_bound(i, n + 1, sum[i - 1] + nearS);
        if(sum[j - 1] - sum[i - 1] == nearS)  //查找成功
            printf("%d-%d\n", i, j - 1);    //输出左端点和右端点(注意是j-1而不是j)
    }
    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值