题目描述
Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:
- Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
- Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
- Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).
Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.
If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.
翻译:在火星购物是一种很特殊的经历。火星人用钻石串付款。每个钻石有一个价值(用火星币表示)。当进行支付时,项链每个位置仅仅只能被剪一次并且钻石会被一颗颗取下来。钻石一旦被取下就不能放回了。举个例子,如果我们有价值分别为 M$3, 2, 1, 5, 4, 6, 8, 7的8颗钻石组成的项链,我们必须付M$15。我们有以下三种付款方式:
1. 从4-6之间将项链割开,然后取下1-5位置的钻石(3+2+1+5+4=15)
2. 从5之前或6之后将项链割开,然后取下4-6位置的钻石(5+4+6=15)
3. 从8之前将项链割开,然后取下7-8位置的钻石(7+8=15)
现在给你钻石项链的各个钻石价值和顾客需要付款的数量,你需要为客户列出所有的付款方式。
如果无法给出精确值,你需要输出损失最少的方案。
INPUT FORMAT
Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=105), the total number of diamonds on the chain, and M (<=108), the amount that the customer has to pay. Then the next line contains N positive numbers D1 … DN (Di<=103 for all i=1, …, N) which are the values of the diamonds. All the numbers in a line are separated by a space.
翻译:每个输入文件包含一组测试数据。对于每组输入数据,第一行包括两个正整数N (<=10^5),项链上的钻石总数,和M(<=10^8),客户需要付的价格。接下来一行包括N个正整数 D1 … DN (Di<=10^3 所有i=1, …, N)代表每个钻石的价值。所有数字中间用空格隔开。
OUTPUT FORMAT
For each test case, print “i-j” in a line for each pair of i <= j such that Di + … + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.
If there is no solution, output “i-j” for pairs of i <= j such that Di + … + Dj > M with (Di + … + Dj - M) minimized. Again all the solutions must be printed in increasing order of i.
It is guaranteed that the total value of diamonds is sufficient to pay the given amount.
翻译:对于每组测试数据,对于每一对符合i<=j且Di+…Dj=M的数输出“i-j”。注意如果有多组解,所有的结果都必须按照i的升序排序。如果没有结果,每一对符合i<=j,Di+…D>M且Di+…D-M最小的数输出“i-j”。同样所有的结果都必须按照i的升序排序。数据保证所有钻石的价值和足够支付M。
Sample Input 1:
16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13
Sample Output 1:
1-5
4-6
7-8
11-11
Sample Input 2:
5 13
2 4 5 7 9
Sample Output 2:
2-4
4-5
解题思路
这道题可以先计算出sum数组再用二分搜索找出每个点的最近数据(再向后减一个就小于M)。也可以用尺取法来解决。我选择的是尺取法,有兴趣的同学可以了解一下。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>
#include<queue>
#include<algorithm>
#define INF 99999999
using namespace std;
struct Node{
int sum,pre,pro;
Node(int s,int a,int b):sum(s),pre(a),pro(b){}
bool operator<(const Node &a)const{
return sum==a.sum?pre>a.pre:sum>a.sum;
}
};
priority_queue<Node> q;
int N,M,d[100010];
int main(){
scanf("%d%d",&N,&M);
int pre=0,temp=0;
for(int i=0;i<N;i++){
scanf("%d",&d[i]);
temp+=d[i];
while(temp>=M){
if(temp-d[pre]<M){
q.push(Node(temp,pre,i));
break;
}else{
temp-=d[pre];
pre++;
}
}
}
int flag=-1;
while(!q.empty()){
Node t=q.top();q.pop();
if(flag==-1)
printf("%d-%d\n",t.pre+1,t.pro+1),flag=t.sum;
else if(t.sum==flag) printf("%d-%d\n",t.pre+1,t.pro+1);
else break;
}
return 0;
}