1044 Shopping in Mars (25)(25 分)(C++)

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M\$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M\$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M\$15. We may have 3 options:

1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).\

  1. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).\
  2. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).\

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=10^5^), the total number of diamonds on the chain, and M (<=10^8^), the amount that the customer has to pay. Then the next line contains N positive numbers D~1~ ... D~N~ (D~i~<=10^3^ for all i=1, ..., N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print "i-j" in a line for each pair of i <= j such that D~i~ + ... + D~j~ = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output "i-j" for pairs of i <= j such that D~i~ + ... + D~j~ > M with (D~i~ + ... + D~j~ - M) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:

16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13

Sample Output 1:

1-5
4-6
7-8
11-11

Sample Input 2:

5 13
2 4 5 7 9

Sample Output 2:

2-4
4-5

解题思路:双指针法,一次遍历,p为左指针,q为右指针,取p=1时,q就遍历到p刚好是p-q的对应的数组的值的和大于等于目标结果,同时设一个临时结果,若此时的结果小于临时结果,且大于等于目标结果就清空目标数组,若等于,则直接存储此时的ij位置,然后p向前遍历,q也相应的前移以再次满足大于等于目标结果的。

#include <iostream>
#include <vector>
using namespace std;
int main(){
	int n, target, p = 0, q = 1, ans = 0, minans = 0x7fffffff;
	scanf("%d %d", &n, &target);
	vector<int>money(n + 1), result;
	money[0] = 0;
	for(int i = 1; i <= n ; ++ i)
		scanf("%d", &money[i]);
	for(; p <= n; ++ p){
		ans -= money[p];
		while(q <= n && ans < target)
			ans += money[q++];
		if(ans >= target && ans < minans){
			minans = ans;
			result.clear();
			result.push_back(p + 1);
			result.push_back(q - 1);
		}
		else if(ans == minans){
			result.push_back(p + 1);
			result.push_back(q - 1);
		}
	}
	for(int i = 0; i < result.size(); i += 2)
		printf("%d-%d\n",result[i], result[i + 1]);
}

 

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值