1101 Quick Sort (25分)

There is a classical process named partition in the famous quick sort algorithm. In this process we typically choose one element as the pivot. Then the elements less than the pivot are moved to its left and those larger than the pivot to its right. Given N distinct positive integers after a run of partition, could you tell how many elements could be the selected pivot for this partition?

For example, given N=5 and the numbers 1, 3, 2, 4, and 5. We have:

1 could be the pivot since there is no element to its left and all the elements to its right are larger than it;
3 must not be the pivot since although all the elements to its left are smaller, the number 2 to its right is less than it as well;
2 must not be the pivot since although all the elements to its right are larger, the number 3 to its left is larger than it as well;
and for the similar reason, 4 and 5 could also be the pivot.
Hence in total there are 3 pivot candidates.

Input Specification:
Each input file contains one test case. For each case, the first line gives a positive integer N (≤10^​5). Then the next line contains N distinct positive integers no larger than 10^​9​​ . The numbers in a line are separated by spaces.

Output Specification:
For each test case, output in the first line the number of pivot candidates. Then in the next line print these candidates in increasing order. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:

5
1 3 2 4 5

Sample Output:

3
1 4 5

题意:
给出一个长度为n的序列,用快速排序寻找主元的思想(主元左边的数都比它小,右边的数都比它大)。输出所有可能的主元。

思路:
1.用leftmax[i]记录a[0]~a[i-1]中最大的数,显然leftmax[0] = 0则leftmax[i-1]表示a[0]~a[i - 2]中最大的数从左到右遍历序列a将其与a[i - 1]比较,若a[i - 1] > leftmax[i - 1],则leftmax[i] = a[i - 1],若a[i - 1] < leftmax[i - 1],则leftmax[i] = leftmax[i - 1](继承关系)
2.同理,用rightmin[i]记录a[i + 1]~a[n - 1]中最小的数,令rightmin[n - 1] = INF(一个很大的数,则rightmin[i + 1]表示a[i + 2]~a[n - 1]中最小的数,从右到左遍历序列a,将其与a[i +1]比较,若a[i + 1] < rightmin[i +1],则rightmin[i] = a[i +1],若a[i + 1] > rightmin[i + 1],则rightmin[i] = rightmin[i + 1](继承关系)

注意:
1.当主元个数为0时,第二行虽然没有主元输出,但必须输出一个换行
2.此题跟B1040/A1093思想很相似

#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn = 100010;
const int INF =0x7fffffff;  //int的最大值
//a为序列,leftMax为左边最大的数,rightMin为右边最小的数
int a[maxn], leftMax[maxn], rightMin[maxn];
//ans存放主元,num为主元的个数
int ans[maxn], num = 0;
int main()
{
    int n;
    scanf("%d", &n);
    for(int i = 0; i < n; i++)
        scanf("%d", &a[i]);     //输入序列
    leftMax[0] = 0;     //a[0]的左边没有比它大的数
    for(int i = 1; i < n; i++)
        leftMax[i] = max(leftMax[i - 1], a[i - 1]);     //由 i - 1推得 i
    rightMin[n - 1] = INF;      //a[n-1]的右边没有比它小的数
    for(int i = n - 2; i >= 0; i--)
        rightMin[i] = min(rightMin[i + 1], a[ i + 1]);  //由 i + 1推得 i
    for(int i = 0; i < n; i++)
        if(leftMax[i] < a[i] && rightMin[i] > a[i])     //左边的数都比他小,右边的数都比他大
            ans[num++] = a[i];  //记录主元
    printf("%d\n", num);
    for(int i = 0; i < num; i++)
    {
        printf("%d", ans[i]);   //输出主元  而不是输出a[i]
        if(i < num - 1)
            printf(" ");
    }
    printf("\n");   //必须有换行符
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值