1078 Hashing (二次探查法)

The task of this problem is simple: insert a sequence of distinct positive integers into a hash table, and output the positions of the input numbers. The hash function is defined to be H(key)=key%TSize where TSize is the maximum size of the hash table. Quadratic probing (with positive increments only) is used to solve the collisions.

Note that the table size is better to be prime. If the maximum size given by the user is not prime, you must re-define the table size to be the smallest prime number which is larger than the size given by the user.

Input Specification:
Each input file contains one test case. For each case, the first line contains two positive numbers: MSize (≤10^​4) and N (≤MSize) which are the user-defined table size and the number of input numbers, respectively. Then N distinct positive integers are given in the next line. All the numbers in a line are separated by a space.

Output Specification:
For each test case, print the corresponding positions (index starts from 0) of the input numbers in one line. All the numbers in a line are separated by a space, and there must be no extra space at the end of the line. In case it is impossible to insert the number, print “-” instead.

Sample Input:

4 4
10 6 4 15

Sample Output:

0 1 4 -

题意:
用户输入哈希表长度Tsize和N个待插入元素,将这写元素插入哈希表中,H(key)=key%TSize,如发生冲突,采用正向增加的二次探查法。如果Tsize不是素数,则需要重新寻找一个大于等于Tsize的素数。

思路:
计算M = a % Tsize,直接用一个hash[M]表示位置是否被使用。产生冲突时,令步长step=1,M = (a + step * step)% Tsize,如果还被占用,step++
注意:
如果step自增到Tsize还没有找到插入位置,则这个元素无法被插入哈希表中。

#include <cstdio>
#include <cmath>
const int N = 10010;
bool hashTable[N] = {false};    //hashTable[i] == false表示i位置没有被占用
bool isPrime(int n)     //判断n是否为素数
{
    if(n <= 1) return false;
    int sqr = (int)sqrt(1.0 * n);
    for(int i = 2; i <= sqr; i++)
        if(n % i == 0)
            return false;
    return true;
}

int main()
{
    int n, Tsize, a;
    scanf("%d%d", &Tsize, &n);      //用户输入的Tsize和待插入哈希表元素的个数
    while(isPrime(Tsize) == false)  //寻找第一个大于等于Tsize的素数
        Tsize++;
    for(int i = 0; i < n; i++)      //对每一个元素枚举
    {
        scanf("%d", &a);
        int M = a % Tsize;
        if(hashTable[M] == false)   //若M位置未被使用
        {
            hashTable[M] = true;    //标记已使用
            if(i == 0)  printf("%d", M);
            else   printf(" %d", M);
        }
        else
        {
            int step;
            for(step = 1; step < Tsize; step++)     //二次探测法
            {
                M = (a + step * step) % Tsize;      
                if(hashTable[M] == false)
                {
                    hashTable[M] = true;
                    if(i == 0)  printf("%d", M);
                    else   printf(" %d", M);
                    break;      //记得break(找到位置了就要中断循环)
                }
            }
            if(step >= Tsize)       //找不到插入的地方
            {
                if(i > 0)
                    printf(" ");
                printf("-");
            }

        }
    }
    return 0;
}


//printf("%d", M);
//if(i < n - 1)
//    printf(" ");




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值