1097 Deduplication on a Linked List (25分)

Given a singly linked list L with integer keys, you are supposed to remove the nodes with duplicated absolute values of the keys. That is, for each value K, only the first node of which the value or absolute value of its key equals K will be kept. At the mean time, all the removed nodes must be kept in a separate list. For example, given L being 21→-15→-15→-7→15, you must output 21→-15→-7, and the removed list -15→15.

Input Specification:
Each input file contains one test case. For each case, the first line contains the address of the first node, and a positive N (≤10^​5) which is the total number of nodes. The address of a node is a 5-digit nonnegative integer, and NULL is represented by −1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the position of the node, Key is an integer of which absolute value is no more than 10^4
​​ , and Next is the position of the next node.

Output Specification:
For each case, output the resulting linked list first, then the removed list. Each node occupies a line, and is printed in the same format as in the input.

Sample Input:

00100 5
99999 -7 87654
23854 -15 00000
87654 15 -1
00000 -15 99999
00100 21 23854

Sample Output:

00100 21 23854
23854 -15 99999
99999 -7 -1
00000 -15 87654
87654 15 -1

题意:
给定一段带有关键字的单链表,要求遍历单链表,去除链表权值的绝对值相同的结点(只保留一个),之后把未删除的结点按链表连接顺序输出,接着把被删除的结点也按在原链表的连接顺序输出。

思路:
1.定义静态链表,用order表示出现顺序,初始化为2*maxn,这样就无效结点就可以被区分开。未被删除的结点的order从0开始编号,被删除的结点的order从maxn开始编号。
2.,设置countValid = 0和countRemoved = 0来记录两种结点,开一个bool数组isExist标记每个结点权值的绝对值是否出现过,初始化为false。
3.枚举链表,如果当前访问结点的权值未出现过,令order = countValid,然后countValid++,否则令order = maxn + countRemoved,然后countRemoved++,这样未被删除的结点就从0开始编号,被删除的结点从maxn开始编号。
3.然后按照order从小到大排序,排完序后,结点的顺序就是,未被删除的结点、被删除的结点、无效结点
4.输出链表,令count = countValid + countRemoved,输出node[0]~node[count - 1]

另外一个思路:
使用两个node的vector存储删除和不删除的输出串,这样当当前key的绝对值访问过时,不需要对该节点进行所谓“删除”操作(即把前面节点的next指向当前结点的next),而是直接放入一个vector ans1中,未访问的结点一样放入一个vector ans2中
这样,因为我们是按链表的顺序访问的,因此vector中的结点也是有序的,只需对输出做稍加修改——每一个结点的next输出为下一个结点的address(即对链表进项“删除”操作后该节点的真正next就是它所在vector中的下一个结点的address)

注意:
1.题目可能出现无效结点。即不在题目给出的首地址开始的链表上
2.注意输出格式

#include <cstdio>
#include <algorithm>
#include <cmath>
#include <cstring>
using namespace std;
const int maxn = 100005;
const int maxc = 1000010;
struct Node     //定义静态链表
{
    int address, data, next;
    int order;  //结点在链表上的序号,无效结点记为2*maxn
}node[maxn];

bool isExist[maxc] = {false};

bool cmp(Node a, Node b)
{
    return a.order < b.order;   //按照序号从小到大排序
}
int main()
{
//    memset(isExist, false, sizeof(isExist));      //定义的时候已经初始化过了,所以可以不用
    for(int i = 0; i < maxn; i++)   //初始化(均为无效结点)
        node[i].order = 2 * maxn;
    int n, begin, address;      //结点个数、首地址
    scanf("%d%d", &begin, &n);
    for(int i = 0; i < n; i++)      //输入所有结点
    {
        scanf("%d", &address);
        scanf("%d%d", &node[address].data, &node[address].next);
        node[address].address = address;
    }
    int countValid = 0, countRemoved = 0, p = begin;    //为删除的有效结点个数和已删除的有效节点个数
    while(p != -1)      //枚举链表
    {
        if(isExist[abs(node[p].data)] == false)     //data的绝对值不存在
//        if(!isExist[abs(node[p].data)])
        {
            isExist[abs(node[p].data)] = true;      //标记为已存在
            node[p].order = countValid++;           //不删除,编号从0开始
        }
        else                                        //data的绝对值已经存在
            node[p].order = maxn + countRemoved++;  //被删除,编号从maxn开始
        p = node[p].next;       //前往下一个结点
    }
    sort(node, node + maxn, cmp);   
    int count = countRemoved + countValid;      //有效节点个数
    for(int i = 0; i < count; i++)
    {
        if(i != countValid - 1 && i != count - 1)   //非最后一个结点
            printf("%05d %d %05d\n", node[i].address, node[i].data, node[i+1].address);
//            printf("%05d %d %05d\n", node[i].address, node[i].data, node[i].next);
//不能这样输出,这样输出的话输出的是原来链表的结构,并不是重构后的结构。
        else
            printf("%05d %d -1\n", node[i].address, node[i].data);      //最后一个结点单独处理
    }
    return 0;
}

code2

#include <bits/stdc++.h>
using namespace std;

const int maxn = 100000;

struct node
{
    int address;
    int key;
    int next;
}List[maxn];

bool vis[10010] = {false};
vector<node> ans1, ans2;

int main()
{
    int start, n;
    scanf("%d%d",&start,&n);
    for(int i = 0; i < n; i++){
        int adr,key,next;
        scanf("%d%d%d",&adr,&key,&next);
        List[adr].address = adr;
        List[adr].key = key;
        List[adr].next = next;
    }
    int adr = start;
    while(adr != -1){
        int value = fabs(List[adr].key);
        if(!vis[value]){
            ans1.push_back(List[adr]);
        }
        else {
            ans2.push_back(List[adr]);
        }
        vis[value] = 1;
        adr = List[adr].next;
    }
    for(int i = 0; i < ans1.size(); i++){
        if(i != ans1.size() - 1)
            printf("%05d %d %05d\n",ans1[i].address, ans1[i].key, ans1[i + 1].address);
        else printf("%05d %d -1\n",ans1[i].address, ans1[i].key);
    }
    for(int i = 0; i < ans2.size(); i++){
        if(i != ans2.size() - 1)
            printf("%05d %d %05d\n",ans2[i].address, ans2[i].key, ans2[i + 1].address);
        else printf("%05d %d -1\n",ans2[i].address, ans2[i].key);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值