1076(并查集) Forwards on Weibo

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

Input Specification:
Each input file contains one test case. For each case, the first line contains 2 positive integers: N (≤1000), the number of users; and L (≤6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

M[i] user_list[i]

where M[i] (≤100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

Then finally a positive K is given, followed by K UserID’s for query.

Output Specification:
For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can trigger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.

Sample Input:

7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6

Sample Output:

4
5

题意:在微博中,每个用户可以关注别人也可以被别人关注,某人发一条微博,关注他的人可以转发这条微博,而转发者的关注者可以再次转发。现在给出N个用户的关注情况以及一个转发层数上限L,给出最初发布消息的用户编号,求在转发层数上限内消息最多会被多少用户转发。

分析:怎么建立图,如果X关注了Y,则应该建立一条Y指向X的有向边,表示Y发布的消息可以到达X

注意:用户编号是1 ~ N,不是0 ~ N - 1。

#include<bits/stdc++.h>
using namespace std;
const int maxn = 1010;

bool inq[maxn] = {false};

struct node
{   
    int id;
    int layer;
};

vector<node> Adj[maxn];


int BFS(int s, int l)       //s起点编号,l为层数上限
{
    int numForwards = 0;    //转发数
    queue<node> q;
    node start;             //定义起始节点
    start.id = s;
    start.layer = 0;        //起始节点层号为0
    q.push(start);
    inq[start.id] = true;   //标记起始节点的编号入队
    while(!q.empty())
    {
        node top = q.front();
        q.pop();
        int u = top.id;     //队首元素编号
        for(int i = 0; i < Adj[u].size(); i++)  //从u出发能到达的所有结点
        {
            node next = Adj[u][i];
            next.layer = top.layer + 1;     //层号+1
            if(inq[next.id] == false && next.layer <= l)    //next的编号未入队且next层数不超过上限l
            {
                q.push(next);
                inq[next.id] = true;
                numForwards++;      //转发数+1
            }
        }
    }
    return numForwards;
}

int main()
{
    int n, l, numFollow, idFollow;
    node user;
    scanf("%d%d", &n, &l);
    for(int i = 1; i <= n; i++)
    {
        user.id = i;    //编号1~n
        scanf("%d", &numFollow);  //编号i关注的人数
        for(int j = 0; j < numFollow; j++)
        {
            scanf("%d", &idFollow);     //i关注的编号
            Adj[idFollow].push_back(user);  //边idFollow->i 注意是把node(user)加入Adj,不是把i加入Adj
        }
    }
    int query, user_id;     //查询个数和用户id
    scanf("%d", &query);
    for(int i = 0; i < query; i++)
    {
        //每次查询都要重新初始化 因为查询完一次之后都要使图变成初始状态(即所有结点都未被访问)
        memset(inq, false, sizeof(inq));    
        scanf("%d", &user_id);
        int ans = BFS(user_id, l);
        printf("%d\n", ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值