描述
用高精度计算出S=1!+2!+3!+…+n!(n≤50)
其中“!”表示阶乘,例如:5!=54321。
输入正整数N,输出计算结果S。
输入
一个正整数N。
输出
计算结果S。
样例输入
5
样例输出
153
解法:
import java.math.BigInteger;
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner in=new Scanner(System.in);
int n=in.nextInt();
BigInteger a=new BigInteger("1");
BigInteger sum=new BigInteger("0");
for(int i=1;i<=n;i++) {
a=new BigInteger("1");
for(int j=1;j<=i;j++) {
BigInteger b=new BigInteger(String.valueOf(j));
a=a.multiply(b);
}
sum=sum.add(a);
}
System.out.println(sum);
}
}