Blocks--递推+矩阵快速幂

ACM专题学习四

Description

Panda has received an assignment of painting a line of blocks. Since Panda is such an intelligent boy, he starts to think of a math problem of painting. Suppose there are N blocks in a line and each block can be paint red, blue, green or yellow. For some myterious reasons, Panda want both the number of red blocks and green blocks to be even numbers. Under such conditions, Panda wants to know the number of different ways to paint these blocks.

Input

The first line of the input contains an integer T(1≤T≤100), the number of test cases. Each of the next T lines contains an integer N(1≤N≤10^9) indicating the number of blocks.

Output

For each test cases, output the number of ways to paint the blocks in a single line. Since the answer may be quite large, you have to module it by 10007.

Sample Input

2   (样例数)
1     
2


Sample Output

2
6

题意

给出n个排成一列的方块,用红、蓝、绿、黄四种颜色给它们染色,求出染成红色的方块个数和染成绿色的方块个数同时为偶数的染色方案的个数模10007的值为多少。

分析

这个题可以用递推的方法

对于 i 个方块,共有三种情况:

1.两种都是偶数,2.一种是奇数,3.两种都是奇数。可以转移到 i + 1 个方块的情况。

对于 i + 1 个方块:

两种都是偶数:第一情况下最后一块涂另外两种颜色之一

                        第二种情况下涂奇数的那种颜色

                         第三种情况无法转移到本状态

一种是奇数:

                        第一种情况下最后一块涂这两种颜色之一

                        第二种情况下涂另外两种颜色之一

                        第三种情况下涂这两种颜色之一

两种都是奇数:

                        第一种情况无法转移到本状态

                        第二种情况下涂偶数的那种颜色

                        第三种情况下涂另外两种颜色之一

写出转移方程组:

A(i+1) = A(i) * 2 + B(i)

B(i+1) = A(i) * 2 + B(i) * 2 + C(i) * 2

C(i+1) = B(i) + C(i) * 2

根据运算法则表达成矩阵

然后根据矩阵的运算法则写代码,并利用矩阵快速幂

代码

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
typedef long long ll;
const int mod = 1e4+7;
struct mat
{
    ll m[3][3];
    mat(){//单位矩阵 
	memset(m, 0, sizeof(m));
    for(int i = 0; i < 3; i++)
        m[i][i] = 1;}
};
mat mul(mat a,mat b)//矩阵乘法 
{
    mat t;
    for(int i = 0; i < 3; i++)
        for(int j = 0; j < 3; j++){
		t.m[i][j]=0;        
            for(int k = 0; k < 3; k++)
                t.m[i][j] = (t.m[i][j]+a.m[i][k]*b.m[k][j])%mod;}
    return t;
}
mat fastpow(mat a, int k)//矩阵快速幂 
{
    mat res;
    while(k)
    {
        if(k&1) res = mul(res, a);
        a = mul(a, a);
        k >>= 1;
    }
    return res;
}
 
int main()
{
    int n, t;
    cin >> t;
    while(t--)
    {
        scanf("%d", &n);
        if(!n) puts("1");
        else
        {
           mat a;//输入矩阵 
            a.m[0][0] = 2; a.m[0][1]  = 1; a.m[0][2] = 0;
            a.m[1][0] = 2; a.m[1][1]  = 2; a.m[1][2] = 2;
            a.m[2][0] = 0;a.m[2][1]  = 1; a.m[2][2] = 2;
            mat ans = fastpow(a, n);
            printf("%d\n", ans.m[0][0]);
        }
    }
    return 0;
} 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值