Binary Number《ACM程序设计》作业

Description

For 2 non-negative integers x and y, f(x, y) is defined as the number of different bits in the binary format of x and y. For example, f(2, 3)=1,f(0, 3)=2, f(5, 10)=4. Now given 2 sets of non-negative integers A and B, for each integer b in B, you should find an integer a in A such that f(a, b) is minimized. If there are more than one such integer in set A, choose the smallest one.

Input

The first line of the input is an integer T (0 < T ≤ 100), indicating the number of test cases. The first line of each test case contains 2 positive integers m and n (0 < m, n ≤ 100), indicating the numbers of integers of the 2 sets A and B, respectively. Then follow (m + n) lines, each of which contains a non-negative integers no larger than 1000000. The first m lines are the integers in set A and the other n lines are the integers in set B.

Output

For each test case you should output n lines, each of which contains the result for each query in a single line.

Sample Input

2
2 5
1
2
1
2
3
4
5
5 2
1000000
9999
1423
3421
0
13245
353

Sample Output

1
2
1
1
1
9999
0

B中的数分别与A中的数比较,算出它们二进制的不同位,取其最小值

*f(2, 3)=1
2-(10)2
3-(11)2
不同的有一位

  • 翻译

描述
对于两个非负整数x和y, f(x, y)定义为x和y的二进制格式中不同的位数,例如f(2,3) =1。f (0, 3) 2。f (5、10) 4。现在给定两组非负整数A和B,对于B中的每一个整数B,你应该找到A中的一个整数A使得f(A, B)最小。如果集合A中有多个这样的整数,选择最小的一个。

输入
输入的第一行是一个整数T (0 <T < 100),表示测试用例的数量。每个测试用例的第一行包含2个正整数m和n (0 < m, n < 100),分别表示两个集合A和B的整数个数。然后是(m + n)行,每一行是一个不大于1000000的非负整数。m行是集合A中的整数,后面n行是集合B中的整数。
输出
对于每个测试用例,您应该输出n行,每一行都包含每个查询的结果。

*第一次写

#include<stdio.h>
int diff(int a,int b)
{
	int count=0;
	while(a||b)
	{
		if((a&1)!=(b&1))
			count++;
		a/=2;
		b/=2;
	}
	return count;
}
int main()
{
	int T,i,j;
	scanf("%d",&T);
	while(T--)
	{
		int m,n;
		int a[101],b[101];
		scanf("%d%d",&m,&n);
		for(i=0;i<m;i++)
			scanf("%d",&a[i]);
		for(i=0;i<n;i++)
			scanf("%d",&b[i]);
		for(i=0;i<n;i++)
		{
			int min=1000000,result=0;
			for(j=0;j<m;j++)
			{
				if(diff(a[j],b[i])<min)
				{
					min=diff(a[j],b[i]);
					result=a[j];
				}
			}			
			printf("%d\n",result);
		}
	}
	return 0;
}

提交上去WA,不知道为什么
然后

#include<stdio.h>
#include<algorithm>
using namespace std;
int diff(int a,int b)
{
	int count=0;
	while(a||b)
	{
		if((a&1)!=(b&1))
			count++;
		a/=2;
		b/=2;
	}
	return count;
}
int main()
{
	int T,i,j;
	scanf("%d",&T);
	while(T--)
	{
		int m,n;
		int a[101],b[101];
		scanf("%d%d",&m,&n);
		for(i=0;i<m;i++)
			scanf("%d",&a[i]);
		for(i=0;i<n;i++)
			scanf("%d",&b[i]);
		sort(a,a+m);
		for(i=0;i<n;i++)
		{
			int min=1000000,result=0;
			for(j=0;j<m;j++)
			{
				if(diff(a[j],b[i])<min)
				{
					min=diff(a[j],b[i]);
					result=a[j];
				}
			}			
			printf("%d\n",result);
		}
	}
	return 0;
}

看出区别了吗?
漏掉了标亮的条件
需要一个排序sort(a,a+m);
AC

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值