Full Binary Tree 2014 SD第五届ACM大学生程序设计竞赛 F


Full Binary Tree
Time Limit: 2000MS Memory limit: 65536K

题目描述

In computer science, a binary tree is a tree data structure in which each node has at most two children. Consider an infinite full binary tree (each node has two children except the leaf nodes) defined as follows. For a node labelled v its left child will be labelled 2 * v and its right child will be labelled 2 * v + 1. The root is labelled as 1.
 
You are given n queries of the form i, j. For each query, you have to print the length of the shortest path between node labelled i and node labelled j.
 

输入

First line contains n(1 ≤ n ≤ 10^5), the number of queries. Each query consists of two space separated integers i and j(1 ≤ i, j ≤ 10^9) in one line.
 

输出

For each query, print the required answer in one line.
 

示例输入

5
1 2
2 3
4 3
1024 2048
3214567 9998877

示例输出

1
2
3
1
44
 
 
求完全二叉树中任意两个节点的最短距离
分别求出两个节点到根节点的路径,依次比较路径,找到第一个不同的节点就是最低公共祖先,然后路径值相加即可,注意对边界情况处理
#include <iostream>
#include <cstring>
using namespace std;

int T,i,j,m,n,k,dis;
int pathi[33],pathj[33];/分别保存i,j节点到根节点的路径


int main()
{
    cin >> T;
    while(T--)
    {
        m = n = 0;

        memset(pathi,0,sizeof(pathi));
        memset(pathj,0,sizeof(pathj));

        cin >> i >> j;
        while(i)//求i路径
        {
           pathi[m++] = i;
           i = i / 2;
        }
        while(j)//求j路径
        {
            pathj[n++] = j;
            j = j / 2;
        }

        m--;n--;
        while(pathi[m] == pathj[n] && m && n) {m--;n--;}//找到最低公共祖先
	//循环结束条件有多种
        if(!n && !m) dis =(pathi[0] == pathj[0]) ? 0 : 2;//当两个下标都为0时,若pathi[0] != payhj[0],则ij为兄弟关系,相同时为父子关系
        else if(pathi[m] == pathj[n])  dis = (!m) ? n : m;//如果pathi[m]==pathj[n],此时一定会有一个下标为0,则取非0的那个下标
        else {m++;n++;dis = m + n;}//此时不会有任何下标为0,即pathi[m++]==pathj[n++]且为最低公共祖先,此时n+1、m+1分别代表i、j到公共祖先
//的距离


        cout << dis << endl;
    }
    return 0;
}

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值