Subsequenc【二分】

题目描述:原题链接

Description
A sequence of N positive integers (10 < N < 100 000), each of them less than or equal 10000, and a positive integer S (S < 100 000 000) are given. Write a program to find the minimal length of the subsequence of consecutive elements of the sequence, the sum of which is greater than or equal to S.(给出N个正整数(10 <100 000)的序列,每个正整数小于或等于10000,并且给出正整数S(S <100 000 000)。编写程序以找到序列的连续元素的子序列的最小长度,其总和大于或等于S.)
Input
The first line is the number of test cases. For each test case the program has to read the numbers N and S, separated by an interval, from the first line. The numbers of the sequence are given in the second line of the test case, separated by intervals. The input will finish with the end of file.(第一行是测试用例的数量。对于每个测试用例,程序必须从第一行读取数字N和S,以间隔分隔。序列的编号在测试用例的第二行中给出,以间隔分开。输入将以文件结尾结束。)
Output
For each the case the program has to print the result on separate line of the output file.if no answer, print 0.
Sample Input
2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5
Sample Output
2
3

解法一:二分

思路:

先进行预处理使num[i]=a[1]+a[2]+…ai。后枚举起点并利用lower_bound函数进行二分查找快速地确定使序列和不小于S的结尾t的最小值。O(logn)

#include<iostream>
#include<algorithm>
#include<cmath>
using namespace std;
int main()
{
	int T;
	cin>>T;
	while(T--)
	{
		int N,S,a[100010],sum[100010]={0};
		cin>>N>>S;
		for(int i=1;i<=N;i++) 
		{
			cin>>a[i];
			sum[i]=sum[i-1]+a[i];
		}
		if(sum[N]<S) 
			cout<<'0'<<endl;continue;
		int res=N;
		for(int s=1;sum[s]+S<=sum[N];s++)
		{
			int t=lower_bound(sum+s,sum+N,sum[s]+S)-sum;
			res=min(res,t-s); 
		}
		cout<<res<<endl;
	} 
}

解法二:尺取

思路:

小于S则右端向右拉一位,大于等于S则记录下长度并与之前得到的符合要求的长度取最小,后左端向右缩一位。O(n)

#include<iostream>
#include<algorithm>
#include<cmath>
using namespace std;
int main()
{
	int M;
	cin>>M;
	while(M--)
	{
		int N,S,a[100010];
		cin>>N>>S;
		for(int i=1;i<=N;i++) cin>>a[i];
		int res=N+1,s=1,t=1,sum=0;
		while(1)
		{
			while(t<=N && sum<S)
				sum+=a[t++];
			if(sum<S) break;
			res=min(res,t-s);
			sum-=a[s++];
		}
		if(res>N) res=0;
		cout<<res<<endl; 
	}
}
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值