A1054 The Dominant Color 难度2

  1. 题目描述

Behind the scenes in the computer's memory, color is always talked about as a series of 24 bits of information for each pixel. In an image, the color with the largest proportional area is called the dominant color. A strictly dominant color takes more than half of the total area. Now given an image of resolution M by N (for example, 800×600), you are supposed to point out the strictly dominant color.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive numbers: M (≤800) and N (≤600) which are the resolutions of the image. Then N lines follow, each contains M digital colors in the range [0,). It is guaranteed that the strictly dominant color exists for each input image. All the numbers in a line are separated by a space.

Output Specification:

For each test case, simply print the dominant color in a line.

Sample Input:

5 3
0 0 255 16777215 24
24 24 0 0 24
24 0 24 24 24

Sample Output:

24
  1. 问题分析

  • 遍历这个图片,看哪个像素个数最多,可以使用hash数组(因为范围很大)或者map

  • 然后遍历map,找到最大的像素的key 即为dominat color

  • 如何读取M个数?scanf()循环就可以

  1. 代码

#include <iostream>
#include <vector>
#include <string>
#include <map>
#include <algorithm>
#include <unordered_map>
#include <cstring>
#include <unordered_set>
#include <sstream>

using namespace std;


int main() {
    int M,N;
    map<long,int >mp;
    long color;
    scanf("%d %d",&M,&N);
    for(int i=0;i<N;i++)
    {
        for(int j=0;j<M;j++)
        {
            scanf("%ld",&color);
            mp[color]++;
        }
    }

    int maxcolornum = -1;
    long maxcolor = -1;
    for(auto it:mp)
    {
       if(it.second>maxcolornum)
       {
           maxcolornum = it.second;
           maxcolor = it.first;
       }
    }
    printf("%ld",maxcolor);
}
  1. 思考与收获

  • 注意使用long

  • 要获取最大值所在的key,不能使用max,max只能获取最大值

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值