A1071 Speech Patterns分数 25

题目描述

People often have a preference among synonyms of the same word. For example, some may prefer "the police", while others may prefer "the cops". Analyzing such patterns can help to narrow down a speaker's identity, which is useful when validating, for example, whether it's still the same person behind an online avatar.

Now given a paragraph of text sampled from someone's speech, can you find the person's most commonly used word?

Input Specification:

Each input file contains one test case. For each case, there is one line of text no more than 1048576 characters in length, terminated by a carriage return \n. The input contains at least one alphanumerical character, i.e., one character from the set [0-9 A-Z a-z].

Output Specification:

For each test case, print in one line the most commonly occurring word in the input text, followed by a space and the number of times it has occurred in the input. If there are more than one such words, print the lexicographically smallest one. The word should be printed in all lower case. Here a "word" is defined as a continuous sequence of alphanumerical characters separated by non-alphanumerical characters or the line beginning/end.

Note that words are case insensitive.

Sample Input:

Can1: "Can a can can a can?  It can!"

Sample Output:

can 5

问题分析

  • 读入一行,然后根据空格来间隔单词,这里是根据非字符非数字进行分割

  • 设置一个map<string,int>,遍历这些单词,进行计数

  • 输出时遍历map,来找到最大值,并返回这个最大值

  • 注意:提前在字符串的最后一个位置加入一个非字符非数字“!”否则下面的代码是在最后直接是个单词的情况下就不能加入map了

收获

  • 如何读入一行

  • `getline`

  • 如何将单词转为小写字母

  • `tolower(str[i])`

  • 如何根据非字符非数字进行分割

  • transform(str.begin(),str.end(),str.begin(), ::towlower);

  • tolower(str[i])

  • 如何判断是字母还是数字?

  • isalpha(str[i])|| isdigit(str[i])

  • isalnum #include <cctype>

  • 一定要注意最后最后结尾没有分隔符的情况

题目评价

难度:三颗星

第三颗星是因为边界条件

代码

#include <iostream>
#include <vector>
#include <string>
#include <map>
#include <algorithm>
#include <unordered_map>
#include <cstring>
#include <unordered_set>
#include <sstream>

using namespace std;


int main() {
   map<string ,int > mp;
   string str;
   getline(cin,str);
//   transform(str.begin(),str.end(),str.begin(), ::towlower);
//   stringstream ss(str);
   string word;
   string tempstr="";
//  如果已经到了最后一位,必须将这个word加入map中,否则就加不进去了
//  为了确保最后一位是有非字母非字符的,人为添加一个  Can1: "Can a can can a can?  It can
str+="!";

   for(int i=0;i<str.length();i++)
   {

       if(isalpha(str[i])|| isdigit(str[i]))
       {
           tempstr+= tolower(str[i]);

       }
       else
       {
           if( tempstr!="" ) //第一次读到非数字非字母
           {
               mp[tempstr]++;
               tempstr="";
           }


       }

   }


   string mostword;
   int numMost = -1;
   for(auto it:mp)//为了确保在个数相同的情况下,只得到字典序最小的,小于等于的都不可以,只有大于的时候才可以替换
   {
       if(it.second>numMost)//这一步很关键,不能反过来
       {
           numMost = it.second;
           mostword = it.first;
       }
   }
   printf("%s %d\n",mostword.c_str(),numMost);
   return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值