一道非常差劲的数论题(筛素数 + 算数基本定理)

It’s said that Aladdin had to solve seven mysteries before getting the Magical Lamp which summons a powerful Genie. Here we are concerned about the first mystery.

Aladdin was about to enter to a magical cave, led by the evil sorcerer who disguised himself as Aladdin’s uncle, found a strange magical flying carpet at the entrance. There were some strange creatures guarding the entrance of the cave. Aladdin could run, but he knew that there was a high chance of getting caught. So, he decided to use the magical flying carpet. The carpet was rectangular shaped, but not square shaped. Aladdin took the carpet and with the help of it he passed the entrance.

Now you are given the area of the carpet and the length of the minimum possible side of the carpet, your task is to find how many types of carpets are possible. For example, the area of the carpet 12, and the minimum possible side of the carpet is 2, then there can be two types of carpets and their sides are: {2, 6} and {3, 4}.

Input

Input starts with an integer T (≤ 4000), denoting the number of test cases.

Each case starts with a line containing two integers: a b (1 ≤ b ≤ a ≤ 1012) where a denotes the area of the carpet and b denotes the minimum possible side of the carpet.

Output

For each case, print the case number and the number of possible carpets.

Sample Input

2

10 2

12 2

Sample Output

Case 1: 1

Case 2: 2

不得不说我已经对这个叫light oj产生阴影了,这道题目真的有两下子,必须预先处理素数,否则会TLE, 有点强的样子,还有要吐槽的地方是就是我不知道我写的是不是正解,但是你TMD搞得b的范围这么大,就算是正解的话只要数据不水肯定会卡时间的。上午的题目真的是有毒,上一个题目明明是ME,却一直弹出RE,真的是有点无语。

希望以后不要做到这个oj上的题目了,真的会让人的心态崩掉, 题目我都懒得用Markdown了。

#include <iostream>
#include <cstring>

using namespace std;


typedef long long LL;

const int N = 1e6 + 10;

int prime[N], idx;

bool vis[N];


void get()
{
    
    vis[1] = true;
    for (int i = 2; i <= 1e6; i ++)
    {
        if(!vis[i])
        for (int j = i + i; j <= 1e6; j += i)
        {
            vis[j] = true;
            
        }
    }
    for (int i = 2; i <= 1e6; i ++)
    {
        if(!vis[i]) prime[idx ++] = i;
        
    }
    
    
    return ;
}

int main()
{
    int T; cin >> T;
    
    int cases = 1;
    
    
    get();
    while (T --)
    {
        LL a, b; cin >> a >> b;
        
        LL ta = a;
        
        if(b * b > a )
        {
            printf("Case %d: 0\n", cases ++);
            continue;
        }
        
        LL res = 1;
        for (int i = 0; prime[i] * prime[i] <= a && i < idx; i ++)
        {
            if(a % prime[i] == 0) 
            {
                int t = 0;
                
                while (a % prime[i] == 0) 
                {
                    t ++;
                    a /= prime[i];
                }
                res *= (t + 1); 
            }
        }
        if(a > 1) res *= 2;
        res = (res) / 2;
        for (LL i = 1; i < b; i ++)
        {
            if(ta % i == 0) res --;
        }
        printf("Case %d: %lld\n", cases ++, res);
    }    
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值