练习赛13 B - Phone List

题目

描述

Given a list of phone numbers, determine if it is consistent in the sense that
no number is the prefix of another. Let’s say the phone catalogue listed these
numbers:
• Emergency 911
• Alice 97 625 999
• Bob 91 12 54 26
In this case, it’s not possible to call Bob, because the central would direct
your call to the emergency line as soon as you had dialled the first three digits of
Bob’s phone number. So this list would not be consistent.
在这里插入图片描述

Input

The first line of input gives a single integer, 1 ≤ t ≤ 40, the number of test cases. Each test case starts
with n, the number of phone numbers, on a separate line, 1 ≤ n ≤ 10000. Then follows n lines with
one unique phone number on each line. A phone number is a sequence of at most ten digits.

Output

For each test case, output ‘YES’ if the list is consistent, or ‘NO’ otherwise.

Sample Input

2
3
911
97625999
91125426
5
113
12340
123440
12345
98346

Sample Output

NO
YES

题解

题意

题目的意思呢很简单就是判断是否存在电话号码是另一个电话号码的前缀。

解题思路

第一种是建树,假设有字符串 a 119 和 b 1199 那么将字符串插入时会有两种情况(a比b先插入,b比a先插入)
a比b先插入:在插入b时会出现b前面几个顶点已经被插入过了,由此可判定b有前缀。
b比a先插入:这种情况在将a插入后会发现最后一个节点的子节点不为空。
建树的思路实现起来代码有点长以前做过一个类似的7-17 哈夫曼编码

在看测试样例的第二部分时,发现输入的5个字符串都排得“整整齐齐”一眼就能看出是否有前缀。于是有了第二种方法,将题目给的字符串(a1,a2 … an)按照字典顺序进行排序,然后利用string类的compare方法判断ai是否是ai+1的前缀即可。

AC代码

#include <iostream>
#include <algorithm>

using namespace std;

bool IsPrefixOf(string a, string b) { // 判断是否是前缀
    return b.compare(0,a.size(),a) == 0;
}

int main() {
    int t;
    cin >> t;
    string phoneNum[10005];
    while (t--) {
        int n;
        cin >> n;
        for (int i=0; i<n; i++) {
            cin >> phoneNum[i];
        }
        sort(phoneNum, phoneNum + n); // 字典排序
        bool flag = false;
        for(int i=0; i<n-1; i++) {
                flag = IsPrefixOf(phoneNum[i], phoneNum[i + 1]);
                if(flag) break; // 出现前缀
        }
//        cout >> endl >> endl; for (int i=0; i<n; i++) cout >> phoneNum[i]; cout >> endl >> endl;
        if(flag)
            cout << "NO" << endl;
        else
            cout << "YES" << endl;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值