POJ3280 Cheapest Palindrome(区间DP)

Description
Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow an electronic ID tag that the system will read as the cows pass by a scanner. Each ID tag’s contents are currently a single string with length M (1 ≤ M ≤ 2,000) characters drawn from an alphabet of N (1 ≤ N ≤ 26) different symbols (namely, the lower-case roman alphabet).
Cows, being the mischievous creatures they are, sometimes try to spoof the system by walking backwards. While a cow whose ID is “abcba” would read the same no matter which direction the she walks, a cow with the ID “abcb” can potentially register as two different IDs (“abcb” and “bcba”).
FJ would like to change the cows’s ID tags so they read the same no matter which direction the cow walks by. For example, “abcb” can be changed by adding “a” at the end to form “abcba” so that the ID is palindromic (reads the same forwards and backwards). Some other ways to change the ID to be palindromic are include adding the three letters “bcb” to the begining to yield the ID “bcbabcb” or removing the letter “a” to yield the ID “bcb”. One can add or remove characters at any location in the string yielding a string longer or shorter than the original string.
Unfortunately as the ID tags are electronic, each character insertion or deletion has a cost (0 ≤ cost ≤ 10,000) which varies depending on exactly which character value to be added or deleted. Given the content of a cow’s ID tag and the cost of inserting or deleting each of the alphabet’s characters, find the minimum cost to change the ID tag so it satisfies FJ’s requirements. An empty ID tag is considered to satisfy the requirements of reading the same forward and backward. Only letters with associated costs can be added to a string.

Input
Line 1: Two space-separated integers: N and M
Line 2: This line contains exactly M characters which constitute the initial ID string
Lines 3…N+2: Each line contains three space-separated entities: a character of the input alphabet and two integers which are respectively the cost of adding and deleting that character.

Output
Line 1: A single line with a single integer that is the minimum cost to change the given name tag.

Sample Input
3 4
abcb
a 1000 1100
b 350 700
c 200 800

Sample Output
900

题目大意

给定一个字符串,由26个英文小写字母组成,告诉你插入或删除某一个字母的代价,求最小代价能使字符串变成回文串。

区间DP

定义dp[i][j]为把字符串第i到第j的字串变成回文串的最小代价。
可以得到
如果字符串第i个字母c[i]==第j的字母c[j]
d p [ i ] [ j ] = d p [ i + 1 ] [ j − 1 ] dp[i][j]=dp[i+1][j-1] dp[i][j]=dp[i+1][j1]
如果c[i]!=c[j]
d p [ i ] [ j ] = dp[i][j]= dp[i][j]=
m i n ( d p [ i + 1 ] [ j ] + 处 理 c [ i ] , d p [ i ] [ j − 1 ] + 处 理 c [ j ] ) min(dp[i+1][j]+处理c[i],dp[i][j-1]+处理c[j]) min(dp[i+1][j]+c[i],dp[i][j1]+c[j])
其中处理是指添加或删除这个字母的较小花费,因为删除和添加是等价的,详细说明一下

如果是在c[j]后添加一个c[i],那么花费就是添加c[i]的花费加上把 c[i+1]到c[j] 变成回文串的花费。
如果是删去c[i],花费就是删去c[i]的花费加上把 c[i+1]到c[j] 变成回文串的花费。
d p [ i + 1 ] [ j ] + m i n ( a d d c [ i ] , d e l e t e c [ i ] ) dp[i+1][j]+min(add c[i],delete c[i]) dp[i+1][j]+min(addc[i],deletec[i])
如果是在c[i]前添加一个c[j],那么花费就是添加c[j]的花费加上把 c[i]到c[j-1] 变成回文串的花费。
如果是删去c[j],花费就是删去c[j]的花费加上把 c[i]到c[j-1] 变成回文串的花费。
d p [ i ] [ j − 1 ] + m i n ( a d d c [ j ] , d e l e t e c [ j ] ) dp[i][j-1]+min(add c[j],delete c[j]) dp[i][j1]+min(addc[j],deletec[j])
合并一下就是DP方程

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<algorithm>
using namespace std; 
int n,m;
char str[2005];
int add_del[50];
int dp[2005][2005];
int main()
{
	scanf("%d%d",&n,&m);
	getchar();
	for(int i=1;i<=m;i++)scanf("%c",str+i);
	for(int i=1;i<=n;i++)
	{
		char c;
		int add,del;
		getchar();
		scanf("%c%d%d",&c,&add,&del);
		add_del[c-'a']=min(add,del);
		//直接预处理
	}
	for(int i=1;i<=m-1;i++)//枚举字串长度,依次转移
		for(int j=1;j<=m-i;j++)//枚举字串左端点
		{
			if(str[j]==str[j+i])dp[j][j+i]=dp[j+1][j+i-1];
			else 
			{
				dp[j][j+i]=min(dp[j+1][j+i]+add_del[str[j]-'a'],dp[j][j+i-1]+add_del[str[j+i]-'a']);
				//核心
			}
		}
	printf("%d",dp[1][m]);
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值