hdu_oj1701ACMer

ACMer

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6516    Accepted Submission(s): 3072


 

Problem Description
There are at least P% and at most Q% students of HDU are ACMers, now I want to know how many students HDU have at least?
 

 

Input
The input contains multiple test cases.
The first line has one integer,represent the number of test cases.
The following N lines each line contains two numbers P and Q(P < Q),which accurate up to 2 decimal places.
 

 

Output
For each test case, output the minumal number of students in HDU.
 

 

Sample Input
 
1
13.00 14.10
 

 

Sample Output
 
15
这就是一道思维题目,但其实这个题目也确实没啥意义,只要想明白题意就可以解决,只要在给出的P%和Q%之间至少有一个人,那么这个总数就是所要的答案,可能遇到的问题就是用1除Q%-P%得到的百分率,这样得到的答案是包含小数点的正正好好的一个人,这是不符合实际情况的
下面是ac代码
#include <iostream>

using namespace std;

int main()
{
    int t;
    cin>>t;
    while(t--)
    {
        int ans=1;
        double a,b;
        cin>>a>>b;
        while(1)
        {
            if((int)(ans*b/100)-(int)(ans*a/100)>=1)
            {
                cout<<ans<<endl;
                break;
            }
            else
                ans++;
        }
    }

    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值