week 15 必做题 ZJM与霍格沃兹

题目

ZJM 为了准备霍格沃兹的期末考试,决心背魔咒词典,一举拿下咒语翻译题
题库格式:[魔咒] 对应功能
背完题库后,ZJM 开始刷题,现共有 N 道题,每道题给出一个字符串,可能是 [魔咒],也可能是对应功能
ZJM 需要识别这个题目给出的是 [魔咒] 还是对应功能,并写出转换的结果,如果在魔咒词典里找不到,输出 “what?”

输入

首先列出魔咒词典中不超过100000条不同的咒语,每条格式为:

[魔咒] 对应功能

其中“魔咒”和“对应功能”分别为长度不超过20和80的字符串,字符串中保证不包含字符“[”和“]”,且“]”和后面的字符串之间有且仅有一个空格。魔咒词典最后一行以“@END@”结束,这一行不属于词典中的词条。
词典之后的一行包含正整数N(<=1000),随后是N个测试用例。每个测试用例占一行,或者给出“[魔咒]”,或者给出“对应功能”。

输出

每个测试用例的输出占一行,输出魔咒对应的功能,或者功能对应的魔咒。如果在词典中查不到,就输出“what?”

样例

样例输入:
[expelliarmus] the disarming charm
[rictusempra] send a jet of silver light to hit the enemy
[tarantallegra] control the movement of one’s legs
[serpensortia] shoot a snake out of the end of one’s wand
[lumos] light the wand
[obliviate] the memory charm
[expecto patronum] send a Patronus to the dementors
[accio] the summoning charm
@END@
4
[lumos]
the summoning charm
[arha]
take me to the sky
样例输出:
light the wand
accio
what?
what?

分析

课上讲的字符串的应用。
步骤:
(1)读取字符串,获取名字和功能
这一步是含空格的行的获取,直接 用getline(cin,str)是比较方便的做法,然后再在这个字符串中根据位置截取名字和功能
(2)建立mp表和vector表。获取名字和功能后就是两个字符串,求取这两个字符串的hash值,采取种子为131,自然溢出的方式。map的结构为map<long long ,int > long long为获取的hash 值, int i 为编号,同时将对应的功能或者是名字存进下标为i 的vector 中。
(3)对于每一个输入,如果是名字的话舍弃[],功能不变,得到str。求字符串的hash 值h,然后查找map 表,如果有记录的话,获得编号i=mp[h],然后在vector 中输出编号为i的数据。

代码

#include<iostream>
#include<string>
#include<map>
#include<vector>
using namespace std;
#define seed 131
map<long long,int> mp;
vector<string> v;
long long Hash(string &s)
{
	long long ans=0,t=seed;
	for(int i=s.length()-1;i>=0;i--)
	{  
		if(s[i]!=' ')
		{
			ans+=s[i]*t;
			t*=t;
		}
	}
	return ans;
}
int main()
{
	string s;
	int i=0;
	while(true)
	{
		getline(cin,s);
		if(s=="@END@") break;
		string name,func;
		name=s.substr(1,s.find(']')-1);
		func=s.substr(s.find(']')+2);
		mp[Hash(name)]=i; v.push_back(func); i++;
		mp[Hash(func)]=i; v.push_back(name); i++;
	}
	/*
	vector<string>::iterator it;
	for(it=v.begin();it!=v.end();it++){
		cout<<(*it)<<endl;
	}
	map<long long ,int>::iterator itt=mp.begin();
	while(itt!=mp.end()){
		cout<<itt->first<<"  "<<itt->second<<endl;
		itt++;
	}*/
	int n;
	scanf("%d",&n);
	getchar();
	string str,ans;
	while(n--)
	{
		getline(cin,str);
		if(str[0]=='[') str=str.substr(1,str.length()-2);
		if(mp.find(Hash(str))==mp.end()) cout<<"what?"<<endl;
		else{
			ans=v[mp[Hash(str)]];
			cout<<ans<<endl;
		}
	}
	return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值