今天仍然是Presentation Error的一天
A Mathematical Curiosity
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 72701 Accepted Submission(s): 19555
Problem DescriptionGiven two integers n and m, count the number of pairs of integers (a,b) such that 0 < a < b < n and (a^2+b^2 +m)/(ab) is an integer.
This problem contains multiple test cases!
The first line of a multiple input is an integer N, then a blank line followed by N input blocks. Each input block is in the format indicated in the problem description. There is a blank line between input blocks.
The output format consists of N output blocks. There is a blank line between output blocks.InputYou will be given a number of cases in the input. Each case is specified by a line containing the integers n and m. The end of input is indicated by a case in which n = m = 0. You may assume that 0 < n <= 100.OutputFor each case, print the case number as well as the number of pairs (a,b) satisfying the given property. Print the output for each case on one line in the format as shown below.Sample Input110 120 330 40 0Sample OutputCase 1: 2Case 2: 4Case 3: 5
import java.util.Scanner;
public class Main {
public static void main(String[] args) {
Scanner scanner=new Scanner(System.in);
int N=scanner.nextInt();
String nullString=scanner.nextLine();
for(int i=0;i<N;i++) {
int k=1;
while(scanner.hasNext()) {
int count=0;
int n=scanner.nextInt();
int m=scanner.nextInt();
if(n==0&&m==0) break;
for(int a=1;a<n;a++) {
for(int b=1;b<n;b++) {
if(a<b && ((a*a+b*b+m)%(a*b))==0) {
count++;
}
}
}
System.out.println("Case "+k+": "+count);
k++;
}
}
scanner.close();
}
}