2019年冬季 7-4 Cartesian Tree (30分)

A Cartesian tree is a binary tree constructed from a sequence of distinct numbers. The tree is heap-ordered, and an inorder traversal returns the original sequence. For example, given the sequence { 8, 15, 3, 4, 1, 5, 12, 10, 18, 6 }, the min-heap Cartesian tree is shown by the figure.

CTree.jpg

Your job is to output the level-order traversal sequence of the min-heap Cartesian tree.

Input Specification:
Each input file contains one test case. Each case starts from giving a positive integer N (≤30), and then N distinct numbers in the next line, separated by a space. All the numbers are in the range of int.

Output Specification:
For each test case, print in a line the level-order traversal sequence of the min-heap Cartesian tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the beginning or the end of the line.

Sample Input:
10
8 15 3 4 1 5 12 10 18 6
Sample Output:
1 3 5 8 4 6 15 10 12 18

这题也太水了……

以前做过LCA的题,用那个题的建树思路就可以

#include <iostream>
#include <queue>
using namespace std;
const int INF = 100005;
struct Node {
    int data;
    Node* left,* right;
    
    Node() {left = right = NULL;}
};

int inOrder[INF];
int N;
void build(Node*& root, int inL, int inR) {
    if (inL > inR)  return ;
    int minNum = INF, minSub = inL;
    
    for (int i = inL; i <= inR; i ++) {
        if (inOrder[i] < minNum) {
            minNum = inOrder[i];
            minSub = i;
        }
    }
    
    int length = minSub - inL;                  //求长度
    if (root == NULL) {
        root = new Node();
        root->data = minNum;
    }
    
    build(root->left, inL, inL + length - 1);
    build(root->right, inL + length + 1, inR);
}

void levelT(Node* root) {
    queue<Node*> qu;
    qu.push(root);
    int num = 0;
    while (!qu.empty()) {
        Node* tNode = qu.front();   qu.pop();
        num ++;
        if (num < N)    cout << tNode->data << " ";
        else cout << tNode->data << endl;
        if (tNode->left != NULL)    qu.push(tNode->left);
        if (tNode->right != NULL)   qu.push(tNode->right);
    }
}

int main() {
    cin >> N;
    for (int i = 0; i < N; i ++)    cin >> inOrder[i];
    
    Node* root = NULL;
    build(root, 0, N - 1);
    levelT(root);
    cin >> N;
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值