SZTUOJ 1003.A+B(III)

Description

Your task is to Calculate a + b.

Input

There are multiple test cases. Each test case contains only one line. Each line consists of a pair of integers a and b ( 1 <= a, b <=10e16 ) , separated by a space. Input is followed by a single line with a = 0, b = 0, which should not be processed.

Output

For each pair of input integers a and b you should output the sum of a and b in one line, and with one line of output for each line in input.

Sample Input

1 5
10 20
10000000000000000 10000000000000000
0 0

Sample Output

6
30
20000000000000000

题目解析

这道题其实和前两个题目没有什么本质上的区别,只是题目要求遇到a和b都等于0的时候退出循环,所以我们不在对比EOF,而是在循环中直接加一个判断条件决定是否结束读入,然后注意题目的数据范围超过了int类型,需要用long long int来存储,除此以外没有其他的更多坑点了。

代码实现

#include<bits/stdc++.h>
using namespace std;
int main()
{
	long long int  a,b;
	while(cin>>a>>b)
    {
        if(a==0&&b==0)break;
        a=a+b;
        printf("%lld\n",a);
    }
	return 0;
} 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值