HDU 1062 Text Reverse

http://acm.hdu.edu.cn/showproblem.php?pid=1062
Problem Description
Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.

Output
For each test case, you should output the text which is processed.

Sample Input
3
olleh !dlrow
m’I morf .udh
I ekil .mca

Sample Output
hello world!
I’m from hdu.
I like acm.

Hint

Remember to use getchar() to read ‘\n’ after the interger T, then you may use gets() to read a line and process it.

常规做法:

#include<bits/stdc++.h>

using namespace std;
char str[1005];
int main(){
    int t;
    cin>>t;
    getchar();
    while(t--){
    gets(str);
    for(int i=0;i<strlen(str);i++){
        if(str[i]==' '){
            for(int k=i-1;k!=-1&&str[k]!=' ';k--){
                cout<<str[k];
            }
            cout<<" ";
        }
        if(i==strlen(str)-1)
        {
            for(int k=i;k!=-1&&str[k]!=' ';k--){
                cout<<str[k];
            }
        }
    }
    cout<<endl;
}
}

用栈stark做:

#include<bits/stdc++.h>

using namespace std;

int main(){
    int t;
    char ch;
    cin>>t;
    getchar();//读取输入t时的空格
    while(t--){
        stack<char>s;//特点是先进后出
        while(true){
            ch=getchar();//每次读入一个字符
            if(ch==' '||ch=='\n'||ch==EOF){
                while(!s.empty()){//s.empty检查栈是否为空,如果为空,返回ture,否者返回false
                    cout<<s.top();//s.top返回栈顶的元素,但不会删除
                    s.pop();//删除栈顶的元素,但不会返回
                    //在出栈时要进行两步操作,即top()获得栈顶元素,在pop()删除栈顶元素
                }
                if(ch=='\n'||ch==EOF)//如果输入换行(即结束)则退出循环
                    break;
                cout<<" ";
            }
            else
                s.push(ch);//把ch放到栈顶
        }
        cout<<endl;
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值