Hdu1062 Text Reverse

Text Reverse

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 27325 Accepted Submission(s): 10639


Problem Description
Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.

Output
For each test case, you should output the text which is processed.

Sample Input
  
  
3 olleh !dlrow m'I morf .udh I ekil .mca

Sample Output
  
  
hello world! I'm from hdu. I like acm.
Hint
Remember to use getchar() to read '\n' after the interger T, then you may use gets() to read a line and process it.

import java.util.Scanner;

public class Main {

	public static void main(String[] args) {
          Scanner sc = new Scanner(System.in);
          int t = sc.nextInt();
          sc.nextLine();
        
          
          while(t-->0){
        	  String str = sc.nextLine()+' ';
        	  char chs[] = str.toCharArray();
        	  int start=0;
              int end=0;
        	  for(int i=0;i<chs.length-1;i++){
        		  
        			  if(chs[i]!=' '&&chs[i+1]==' '){
        				  end = i;
        				  for(int j=start;j<=start+(end-start)/2;j++){
        					  reverse(chs,j,end-j+start);
        				  }
        			  }	  
        		      if(chs[i]==' '&&chs[i+1]!=' '){
        		    	  start = i+1;
        		      }
        	  }
        	  
        	  for(int i=0;i<chs.length-1;i++){
        		  System.out.print(chs[i]);
        	  }
        	  System.out.println();
          }
	}
	public static void reverse(char[] chs,int x,int y) {
		char ch = chs[x];
        chs[x] = chs[y];
        chs[y] = ch;
	}
}

这个题目比较坑,前后都可以有空格,空格也可以有多个,而且所有的空格要原样输出。

解析:找到每个单词反转一下即可。


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值